5. Web Survey: Surveys through the Internet

Introduction

The Epi Info™ Web Survey System allows the survey designer to collect information from participants over the Internet. The ability to distribute and collect surveys remotely is unique to Epi Info™ 7 and provides survey designers access to a wide variety and number of participants. Survey forms can be published to any properly configured web server hosted by your institution or an outside party. When published, Epi Info™ creates a survey specific Universal Resource Locator (URL) or website address. The survey designer can distribute the URL over email, by posting it on a web page, or using other methods. Participants access the web survey and submit their responses through a web browser or mobile device. After the participant submits the response, the survey designer downloads the response directly into the original Epi Info™ 7 project for analysis.

Figure 5.1: Web Survey System
Epi Info™ Web Survey System Deployment

The Epi Info™ Web Survey System is a companion to the Epi Info™ 7 suite of tools, and a separate package apart from Epi Info™ 7. The Web Survey System requires a server running Microsoft Internet Information Services or IIS and a SQL Server database. This database manages the users authorized to publish surveys, published web surveys, and the data submitted by respondents. Without access to the web and database servers that host the Epi Info™ Web Survey System, users will not be able to publish surveys and collect data over the Internet using Epi Info™.

Additional information about the Epi Info™ Web Survey System is located on the Epi Info™ Web Survey page (www.cdc.gov/epiinfo/eiws/index.htm). This site contains setup instructions and links to download the free deployment package kit.

This user guide outlines the steps required to design and publish a form using the Epi Info™ 7 Form Designer tool, and import data submitted by survey participants with the Epi Info™ 7 Enter tool. The technical aspects of configuring the web and database servers are beyond the scope of this guide.

To obtain the necessary keys and settings to use the Web Survey System, contact your Web Survey System administrator, or the person/group that manages the Epi Info™ Web Survey System in your organization.

Designing Forms for the Web

The Epi Info™ Web Survey System allows for publishing short, single form projects (without grids or related forms) to the web for online data entry. This design creates certain features and behavioral differences between the web survey format and the full Epi Info™ functionality. Be aware of these differences and plan for them when designing a survey. For example, not all field types or check code commands are supported or provide value on a web survey. Additionally, required fields and drop-down lists may behave differently on a browser than they do on the Epi Info™ 7 Enter tool.

Before creating a survey, set the computer resolution to 1366 x 768 or 1024 x 768. These are the two most common screen resolutions in use today according to GS.StatCounter.com. If participants take the survey on an average non-mobile browser, this adjustment aligns the resolution to that of the most common participant. This will mitigate any discrepancies between how the survey appears to the designer and the participant.

These specifications are not necessary for participants using browsers on smart phones, tablets or other mobile devices. The Epi Info™ Web Survey System automatically adjusts the display when a survey is accessed with a mobile device. Surveys for these small screen-
sized devices appear with a stacked question arrangement by tab order. For small mobile devices, horizontal field placement is irrelevant, as the fields appear one above the next.

After creating a new blank project, but before adding fields to the page, consider the page layout and size. A ‘landscape’ page orientation provides more width than height, which is consistent with most web pages. To set the page size and orientation, select Format > Page Setup from the menu. On the Size drop-down list, select the size to use or select Custom and enter the width and height in pixels. On the Orientation group, select the Landscape option.

**Supported Field Types**

The Web Survey System does not support all field types available in the Form Designer tool. See below for a list of supported and non-supported field types.

**Supported field types:**
- Label/Title
- Text (single line)
- Multiline (text)
- Number
- Date
- Time (not “Date/Time”)
- Checkbox
- Yes/No
- Option
- Legal Values
- Comment Legal
- Codes
- Group

**Non-Supported field types:**
- Text (Uppercase)
- Unique Identifier
- Phone Number
- Date/Time
- Command Button
- Image
- Mirror
- Grid
- Relate

If a survey contains one or more of the non-supported field types, a message will identify the field(s) that will not publish. To publish the survey, perform one of the following two actions:

1. Delete the unsupported field(s). This will also delete any data that may have been in the Epi Info™ 7 Enter tool. If you want to preserve pre-existing data, make a project template and create a new project that you will customize for web publishing. In this new project, delete the non-supported fields.
2. If a data table does not exist for the form, you can use the “Change To” feature to change the field type to one of the supported types. For example, you can change an unsupported Text (Uppercase) field to a standard Text field or a Multiline field.
Supported Check Code Commands and Functions

The Web Survey tool does not support all Check Code commands and functions available in the Form Designer tool. See below for a list of supported and non-supported commands and functions.

**Supported Commands:**
- Assign
- Clear
- Dialog
  - Simple Dialog only
- Enable / Disable,
- Go To
- Hide / Unhide
- Highlight / Unhighlight
- If / Then / Else
- Set-Required / Set-Not-Required

**Non-Supported Commands:**
- AutoSearch
- Define
- Dialog
  - Get Variable Dialog
  - List of Values Dialog
- Execute
- Geocode
- Help
- NewRecord
- Quit

**Supported Functions:**
- ABS
- Cos
- Day
- Days
- FindText
- Hour
- Hours
- LN
- LOG
- Minute
- Minutes
- Month
- Months
- Rnd
- Round
- Second
- Seconds
- Sin
- StrLen
- Substring
- SystemDate
- SystemTime
- Tan
- Trunc
- UpperCase
- Year
- Years

**Non-Supported Functions:**
- CurrentUser
- DateDiff
- Date
- Environ
- EpiWeek
- Exists
- Exp
- FileDate
- Format
- Linebreak
- NumToDate
- NumToTime
- PFROMZ
- RecordCount
- Step
- TxtToDate
- TxtToNum
- ZSCORE

Although the non-supported commands and functions do not work when entering data into the web survey, they are still compatible with Check Code on the downloaded version of the survey. After downloading the web survey responses, you can run these commands and functions as normal, or you can use Epi Info™ 7 Analysis tool to perform the necessary operation.
Differences in Check Code Performance

In Check Code, the designer places commands within field blocks for actions such as ‘Before’, ‘After’, and for some field types, ‘Click’. The key variation in performance between Check Code in the Enter tool and the Web Survey is related to the After block for fields that have drop-down lists (such as Yes/No, Legal Values, Comment Legal, and Codes).

In Enter, Check Code in the After block for fields executes when you leave the field either by tabbing to the next field or by clicking on another field on the page. However, in the Web Survey System, the Check Code in the After block for these fields executes as soon as you make a selection. The variation occurs since navigation is typically done by mouse and without a Tab key in the Web Survey System. Therefore, any Check Code commands (i.e. Enable/Disable, Hide/Unhide, Highlight/Unhighlight, and Set-Required/Set-Not-Required, etc.) that depend on the value selected in the drop-down list will occur as soon as the selection is made.

The Required property requires the participant to enter a value for the specified field. In the Enter tool, required fields must contain a value for the respondent to save the record or navigate to a different record. In the Web Survey tool, access to a separate page is also denied if a required field is left blank. If a required field is blank, a message displays notifying the participant that values must be given for required fields before the response can be submitted.

Confirm Web Survey Compatibility

To ensure the web survey functions properly, check the tab order and enter test data into the survey. Additionally, practice sample analyses on the test data before publishing the form.

A logical tab order is critical, especially if the participant might use a mobile device like a smart phone or tablet computer. As previously mentioned, tab order determines the order in which the fields are displayed on the mobile device. Even if the survey participant will use a desktop or laptop, any Check Code used to validate the data entry may depend on a logical tab order. For information regarding Tab Order, refer to the Form Designer section – How To: Set Tab Order.

Review all field names to ensure each is concise and logical. Field names cannot be changed after publishing the final version. A user-friendly way to check the field names is with the Data Dictionary feature. For information regarding Data Dictionary, refer to the Form Designer section – How To: View a Data Dictionary.
With the tab order and field names confirmed, enter sample test records. Click the **Enter Data** button from the Form Designer menu bar to preview the form in the Enter tool. When entering test data, record any changes that need to be made prior to publishing the survey. Check the field validation to determine if the field should be required, or if there is a valid range for number and date fields, or any other Check Code that may be used.

With test data in the form, attempt the analyses you anticipate performing. Confirm the field names are clear and easy to use. If you intend to use a tool other than Epi Info™ 7 for analysis, export the test data in the desired format. Common corrections include resetting a long field name, or changing/adding a field type.

*Note: Corrections can only be made before the survey is distributed to participants for data collection.*

Next, practice publishing the survey as a test by following the Publish Form to Web instructions. Confirm that you can successfully publish the form, navigate among the pages, enter more test data, and reconfirm the validations and Check Code behavior is all working properly. To ensure full functionality, download the test data and perform a sample analysis. If an error is observed, make the necessary corrections and repeat this step until the survey functions as desired.

When testing is complete, remove all test data using the Delete Data Table function and publish the final version. For information regarding Delete Data Table, refer to the Form Designer section – How To: Delete an Existing Data Table Without Deleting the Form.

**Initial Setup**

Publishing a survey and collecting data requires information that is either provided by the Web Survey System administrator or generated by the Web Survey System. This information provides security to the system and access to individual surveys. The following are key terms used in Web Survey:

- **Endpoint Address** – designates the location or URL of the application that hosts surveys.
- **Organization Key** – provides survey designer access to publish the survey and import the responses.
- **Survey Key** – identifies the survey that corresponds to the Security Token for downloading data.
- **Security Token** – grants access to the survey data and prevents others with the Organization Key and Survey Key from accessing the data.

Before publishing a survey, the designer must designate the endpoint address and binding protocol.

1. Contact your Web Survey System administrator for the following:
   - **Endpoint Address**
- Use of Windows Authentication (Yes or No)
- Binding Protocol (basic or wsHTTP)
- Organization Key

2. From the Epi Info™ Form Designer menu, select **Tools > Options**.

3. Click on the **Web Survey** tab. The **Web Survey Options** dialog box appears.

![Web Survey Options dialog box](image)

4. Enter the **Endpoint address**, and then make your **Windows Authentication**, and **Binding Protocol** selections. The Web Survey System administrator provides this information. An example of an endpoint address is:

### Publish Form to Web

After designing a form that is compatible with the Web Survey System, the survey can be published to the web server. With the completed form open in Form Designer, complete the following steps.

1. From the Form Designer menu, select **File > Publish Form to Web**.
2. If a form contains a non-supported field type, an error message occurs stating the name of each invalid field.

![Unsupported Field Types error message]

To meet publishing requirements, delete or change the field type of non-supported fields. Before deleting a field, be aware that any data collected with that field will be deleted as well. The data removal is automatic and irreversible. Consider backing up all data prior to deleting a field. Alternatively, use the Change To option to change the field to a supported field type. This action can only be performed if there is not a data table associated with the form. For information regarding Delete Data Table, refer to the Form Designer section – How To: Delete an Existing Data Table Without Deleting the Form.

*Note: Data tables are created when the form is accessed with the Enter Data tool, regardless of whether data has been collected. To remove a data table, select Tools>Delete Data Table.*
3. In the Publish Form to Web dialog box, there are three tabs that must be filled out prior to publishing the survey:

- **Introduction Page** – provides information to the survey participant prior to beginning the survey
- **Exit Page** – provides closing remarks to the survey participant after the survey is submitted
- **Publish Options** – specifies technical aspects of the web survey posting process

The following navigation buttons are at the bottom of the dialog box:

- The **Next** button saves the information and proceeds to the next tab.
- The **Clear** button removes all entries from the page and returns the user to a blank Introduction Page.
- The **Cancel** button allows the user to exit the Publish Form to Web dialog box and return to the Form Designer window.
- The **OK** button will attempt to publish the survey. If any information is omitted, an error message will appear.
4. On the Introduction Page tab, click in the **Give Your Survey a Title (required)** textbox to enter the survey title. This title will appear at the top of each page in the survey.

5. Enter your **Survey Number or ID**,** Organization Name** and **Department Name**. This information appears at the top of the introduction and exit pages.

*Note: The Organization Name is used for tracking purposes only. The Organization Key is the key that allows you to post a survey to the web server. The Organization Key should be kept secure and confidential.*

**DO NOT PUT THE ORGANIZATION KEY INTO THE ‘Organization Name’ FIELD ON THE INTRODUCTION TAB.**

6. The **Welcome!** textbox provides participants with a greeting, special instructions or additional information about the survey. Click in the **Welcome!** textbox and enter a message.
7. Select the survey closing date from the **Survey Closing Date** drop-down menu located below the **Welcome!** textbox. This field only accepts a date in the future.

*Note: The default setting is 10 days from the current date.*

At 11:59:59.99 pm on the selected survey closing date, any attempt to access the survey will prompt the message below.
8. Click **Next** to save this information and proceed to the Exit Page tab.

*Note: The Introduction Page can be edited at any point prior to publishing the survey by clicking on the Introduction Page tab.*

![Figure 5.10: Exit Page](image)

9. The Exit Page displays closing remarks or additional instructions about the survey. Enter your comments in the textbox next to the green check mark. This example states “Thank you for completing this survey.” The Survey #, Organization and Department fields will automatically populate based on the information provided in the Introduction Page tab. Clicking on either of these fields will direct you back to the Introduction Page.

10. Click **Next** to proceed to the Publish Options tab.
11. To allow a participant to submit more than one response in a given session, select the Many responses allowed option button. The default setting is One response only, which closes the survey after the participant submits one record.

Note: Selecting “One response only” will not prevent a participant from accessing a survey link more than once.

12. Enter/Paste the Organization Key provided by the Web Survey System administrator.

Hint: If the organization key is provided in an email or other electronic file, copy and paste the key into the organization key field to avoid any mistakes. The organization key must be a valid global unique identifier to enable the Publish Form button. An example of an Organization Key is “3f6c6251-4af6-40f7-a440-cb2a9ca92e17.”

13. Click Publish Form.

If an error message appears, contact your Web Survey System administrator with the text displayed in the Form Publish Status field. Click the associated Log button to access detailed information regarding the error message if available. Typically, this error occurs with an invalid or missing endpoint address.

After successfully publishing the survey, the URL, Survey Key and Security Token fields will automatically populate. Survey participants will use this URL to access the survey.

14. Click the Copy All to Clipboard button. Save this information in a document or a format of your choosing for future use.
Important: The URL, survey key and security token are all required to access the survey and survey data. The security token cannot be recreated if it is lost. Keep the security token in a secure location. DO NOT SHARE THE SECURITY TOKEN WITH SURVEY PARTICIPANTS.

Invite Participants to Take the Survey

After publishing the survey, participants can access the web survey at any time up to and including the survey closing date. The survey can be accessed using the URL generated in the Publish Form to Web steps in the previous section. Designers can invite participants by distributing the web address or URL over email, by posting it on a web page, or using other methods.

Access the Survey Using the URL

1. Launch your web browser. Copy and paste the URL into the address bar at the top of your browser window. If the survey is not closed, the survey Welcome! page appears.

   ![Epi Info Survey Welcome Page](image)

   **Figure 5.12: Survey Welcome Page**

2. Click **Begin Survey**. The first page of the survey appears.
Enter your response to each survey question. You can go to the next page of the survey by clicking on the navigation buttons on the top left corner of the screen. You can also click the Continue button at the bottom of the page to navigate between pages. The information entered into the form is not saved until Submit Survey button or the Finish Later button at the bottom of the page is clicked. For information regarding the Finish Later button, refer to the Saving Survey Answers for Future Submission topic.
Submitting Survey Responses

1. After completing the last page of the survey, click **Submit Survey** to send the response.

   ![Submit Survey](image1.png)

   **Figure 5.15: Submit Survey**

2. The **Exit Page** appears and displays the thank you message.

   ![Survey Exit Page](image2.png)

   **Figure 5.16: Survey Exit Page**
3. If the **Many responses allowed** option was selected in the Publish Options tab, the Start Survey Again message will appear allowing the participant to submit more than one response. This is useful when one participant is entering multiple responses to the survey.

![Start Survey Again](image)

**Figure 5.17: Start Survey Again**

## Saving Survey Answers for Future Submission

If the survey cannot be completed in one sitting, participants can save the survey and finish their responses at a later time.

1. To save a survey, click the green **Finish later** button located at the bottom of each page in the survey.

![Finish later button](image)

**Figure 5.18: Finish Survey later**

A dialog box appears with a Survey Link and Pass Code.
2. Copy and save the Survey Link and Pass Code. This information is required to return to the survey at a later time. The saved survey contains all information entered into the form and cannot be retrieved by the participant without the Survey Link and Pass Code. If the participant loses the Pass Code or Survey Link, the participant will need to take the survey from the beginning.

There is an option to email the Survey Link and Pass Code. The email address is not saved in the system and is only used to generate the outgoing email.

3. Enter a valid email address in the Email textbox.

4. Re-enter the email address in the Confirm Email textbox.

5. Click Send. The participant will receive the Survey Link and Pass Code via email.

6. To complete the survey, copy and paste the Survey Link into a web browser or click the link in the email.

7. Enter the Pass Code into the Pass Code textbox. Click Go.
The saved survey form appears containing all information previously entered.
Importing Survey Data

1. From the Epi Info™ main menu, select Enter Data or select Tools > Enter Data. The Enter tool opens.

2. Open the project and form used to publish the web survey.

3. From the File menu, select Import Data > From Web.

4. Enter the Web Survey Key, Organization Key, and Security Token into the Import web form data dialog box (Refer to Publish Form to Web, Step 13 for this information.)

Figure 5.22: Import Data from Web
5. Click **Import**.

*Note: If you incur an error message, ensure that the endpoint address is entered in the Web Survey dialog box.*

6. After the import is complete, click **Close**. The responses to the survey questions appear in the survey form and are added to your Epi Info™ database. The import process can be executed multiple times and will append newly submitted responses without creating duplicate records.
The data collected is now ready for analysis. Refer to the Visual Dashboard or Classic Analysis sections of this user guide for further information about analysis.