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 Form Designer 2.

Introduction  

 

In Epi Info™ 7, the Form Designer and the Enter modules work together to design the data 

entry process and collect data. Form Designer is the tool used to design the survey, 

questionnaire, or form, tailor the data entry process, and specify the tab sequence. It is 

where you customize any data validation you want to occur when the form receives data in 

the Enter tool. 

Data collection in Epi Info™ 7 is organized by projects. Each project can have one or many 

forms which can have one or many pages. On each page, one or many data entry fields are 

added which collect individual data elements.  

 
Figure Error! No text of specified style in document..1: Project Organization 

Fields added to a page can be any of a variety of field types corresponding to the type of 

data needed and the kinds of analyses that can be anticipated. Field types range from 

simple labels, text, numeric, and date fields to more advanced fields like drop-down lists, 

data grids, and command buttons. A list of the available field types is shown in Figure 2.21.  

Epi Info™ 7 normally uses the Microsoft Access database format.  If no changes are made 

to the default settings when new projects are created, data are stored in the project’s MS 
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Access data file having an “.mdb” extension.   If you have access to a Microsoft  SQL Server 

database, Epi Info™ 7 can natively use this format for data storage, instead of the MS 

Access format.  Epi Info™ 7 handles all of the database management aspects such as the 

table creation, managing keys, relationships, and other information storage details. Since 

the process of designing the form also defines the database, the Form Designer can be 

regarded as a type of database design environment. 

Navigate the Form Designer Workspace 

 

To open Form Designer, click Create Forms from the Epi Info™ 7 - Menu, or select 

Tools > Create Forms from the toolbar.  

 

Figure Error! No text of specified style in document..2: Create Forms Menu Option 
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Figure Error! No text of specified style in document..3 Form Designer (No Active Project) 

1. The Menu toolbar provides an easy way to access your projects and gives you tools 

to edit your forms, manage your project and customize your Canvas. 

2. The Project Explorer is located on the left of the screen and allows you to add 

pages, fields, and templates to a form. Each category can be collapsed or expanded 

by clicking their respective – or + buttons next to the category name.  

3. The blank page to the right of the Project Explorer is the Canvas where the form is 

designed. Each field is defined and edited using its Field Definition dialog box. You 

can customize the work space by selecting fonts, colors, and grid options.  

 

Open a Recent Project 

Epi Info™ 7 is packaged with many sample projects, templates, and examples to use for 

helping to showcase its many features and functions.  The Sample project is one that 

contains several forms already prepared with instructional data collected.  Many of these 

forms and their associated data are used in schools of public health for teaching Epi Info™ 

and the science of epidemiology and statistics important to public health research and 

epidemiologic investigations. 

To open a recent project, from the Form Designer menu, select File > Recent Projects. 
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A list of recently opened projects is shown in the menu.  Even though this may be the first 

time opening Form Designer, the Sample project is shown in the list to get you started. 

 

Figure Error! No text of specified style in document..4: Opening a Recent Project 
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After selecting the Sample project, Form Designer opens to the first page of the first form – 

ADD Full.  

 

Figure Error! No text of specified style in document..5: Form Designer First Page of Project 
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Create a New Blank Project and Form 

Every Epi Info™ 7 project could contain two files; the database file and a project file (.prj) 

that is contained in a project folder. The project file holds the information about the location 

and format of the database, and whatever connection information might be required, such 

as a user name and password. If you choose to use the Microsoft Access format for your 

database, your project may also have the database file (.mdb) inside the project folder. The 

database file can also be saved to another location as needed. Projects that use a SQL 

Server database will only have the .prj file since the database is located on the server. 

To create a new project and form, follow the steps below: 

1. From the Epi Info main menu, select Create Forms or select Tools > Create 

Forms from the toolbar. The Form Designer window opens. 

2. Click the New Project button in the toolbar or select File > New Project. The 

New Project window opens. 

 
Figure Error! No text of specified style in document..6: New Project dialog box 
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3. Enter a Project Name. Project names cannot contain spaces, or most non-

alphanumeric characters, although underscores are permitted. 

4. Set the desired project location by typing it into the Location field, or clicking the 

browse button. The default location for projects is the \Epi Info 7\Projects folder. 

5. Provide a description of the project. (Optional) 

6. Select the database format from the Data Repository drop-down list. The default 

option is Microsoft Access 2000-2003.  However, SQL Server is also available. To use 

the SQL Server option, you need to have access to a SQL Server database. 

7. If you selected Microsoft SQL Server for the Data Repository, then click the 

browse button to the right to enter the connection information for the SQL Server 

database. Contact your SQL Server database administrator for the required 

information requested in this dialog box. 

 

 
Figure Error! No text of specified style in document..7: SQL Server Database dialog box 

8. Click OK. 

9. Tab to, or select the Form Name field. 

10. Enter a Form Name. 

 Use only letters, numbers, and underscores. 

 Do not start a form name with a number. 
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 Do not use any spaces. 

11. Click OK. A new blank canvas appears with the new form name and page on the tab 

at the top left of the canvas. 

 

Before You Begin 

Decide on a Naming Convention for Field Names 

Before beginning to design your form it is helpful to have a standard way to name the data 

fields.  While Epi Info™ will attempt to suggest a field name based on the question or 

prompt, in many cases these suggestions are too lengthy or cumbersome. Having a 

standard naming convention to assign to fields as they are added to the form will make 

later analyses much easier.  The following suggestions may help: 

 Keep field names short.   

 Capitalize words within field names to help improve their readability.  

For example, "PatientLastName" is easier to read than "patientlastname". 

 Use a prefix to keep associated fields together in alphabetized lists.   

Customize the Form Designer 

One of the most helpful things you can do before beginning to develop your questionnaire or 

survey form is to decide on the layout and overall look of the form.   

Aspects to consider include the following: 

 What Font do you want the Questions and Entry Fields to have?  You may want 

to set the Default Prompt and Input Fonts.  You specify the fonts in 

Format>Set Default Prompt Font and Set Default Input Font. 

 How far apart should fields be spaced?   You may want to adjust the settings for 

the grid.  The grid square size and other grid settings are set in Format > Grid 

Settings. 

 Will the form need to be printed?  If so, what size paper will likely be used?  You 

may want to use a corresponding page size when designing the form.  You specify 

the page size in Format > Page Setup. 

 What page orientation should be used, Portrait or Landscape?  The answer to 

this may depend on what devices and platform will be used for data entry.  If the 

form will be published to a website or uploaded to a mobile device, consider a 

smaller page size and an appropriate page orientation.  The page orientation is 

set in Format > Page Setup. 



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-9 

 

 Would you prefer the Question or Prompt to appear above the Input Field or to 

the left of the Input Field?  You set the question and input field positioning in 

Format > Page Setup and select Vertical or Horizontal. 

 What screen resolution will likely be used for data entry?  If the anticipated 

screen resolution is less than your usually setting, you may consider reducing 

your resolution while designing the form so the layout of your fields will be 

consistent when viewed in the Enter tool.   

While you can change these format settings at any time during the form design, if these 

questions are considered earlier, there may be less rework required to make the form 

presentable than if these settings are changed after fields are added to the pages. 

 

  



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-10 

 

Set a Default Prompt or Input Field Font  

Set the character font to be used as fields are added to the form using the Format menu. 

Default Prompt Font 

1. Format > Set Default Prompt Font. The Font dialog box appears. 

2. Select a font, font style, and sizes. 

3. Click OK.  

Default Input Font 

1. Format > Set Default Input Font. 

2. Select a font, font style, and sizes. 

3. Click OK.  

Change Grid Settings 

Use the Format settings to customize the Form Designer canvas. 

1. From the Form Designer toolbar, select Format. The drop-down menu opens 

allowing you to customize your canvas. 

2. Select Format > Grid Settings to open the grid settings dialog box.  

 
Figure Error! No text of specified style in document..8: Grid Settings 

 Check the Snap to Grid box to force fields in the form to snap to the grid 

nearest the field edge. 
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 Check the Show Grid box to see the grid as the canvas background. 

 Use the up and down arrows in the Grid Square Size field to alter the 

displayed width between grid lines. 

 Select the Snap prompt to grid or Snap entry field to grid check boxes 

depending on the snapping effect you want to use. 

3. Click OK. The Form Designer page appears with new settings. 

Set the Page Size, Orientation, and Default Prompt Alignment 

The Page Size, Orientation, and Default Prompt Alignment are set using the Page Setup 

dialog.   

 

Figure Error! No text of specified style in document..9: Page Setup 

1. On the Form Designer menu, select Format > Page Setup.   
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2. Set the page size to be any of the pre-configured sizes listed in the Size drop-down 

list or use a Custom Size and specify the Width and Height in pixels. 

 

Figure Error! No text of specified style in document..10: Page Size Setup 

3. Set the preferred page orientation – Portrait or Landscape. 

 Portrait orientation is good for data entry forms that need to be printed and 

when the data entry is done from printed forms that have a portrait orientation.   

Portrait orientation may also be preferred for forms uploaded to small mobile 

devices such as smart phones or tablets. 

 Landscape orientation is better for forms intended to be published to a website 

for entry using an Internet browser on a desktop or laptop computer. 

Set the default alignment to be vertical so the field is below the prompt and left 

aligned, or horizontal where the field is to the right of the prompt on the same row.  
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Figure Error! No text of specified style in document..11: Page Setup dialog showing Default Label-Field 

Alignment 

 

Insert a Background Image or Color 

1. From the Form Designer toolbar, select Format > Background. The Background 

dialog box opens. 
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Figure Error! No text of specified style in document..12: Background Format 

2. To set a background image, use the Background Image section of the dialog, click 

Choose Image. The Background Image box opens.  

3. Locate the image file. Click Open. The selected image appears in the Background 

Image dialog box. Image formats include bitmap (.bmp), picture (.ico), and JPEG 

(.jpg).  

4. Use the Image Layout drop-down list to customize the image on the screen (None, 

Tile, Center, and Stretch). 

5. From the Image and Color section, use the option buttons to Apply to all pages or 

Apply to the current page only. 

6. Click OK. The image appears in the form. 

7. To remove the image, select Clear Image from the Background Image box.  

8. To set a background color, click Change Color. The Color dialog box opens.  

9. Select a background color from the palette or select Define Custom Colors to 

enter a more specific color request. 

10. Click OK. The selected color previews in the background box. 

11. From the Image and Color section, use the option buttons to Apply to all pages or 

Apply to the current page only. 
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12. Click OK. The color appears in the form as a background. 

13. To remove the color, select Clear Color from the Background Color box.  

 

Create a New Project from a Project Template 

Another way to create a new project is to use a pre-defined project template.  This option 

creates the project with all of the forms, pages, fields, and Check Code that are specified in 

the project template.  Epi Info™ 7 comes with a number of sample project templates to 

demonstrate its many features. These templates are located in the Project Explorer under 

Templates > Projects.   

To use an existing project template, follow the steps below: 

1. Select File > New Project from Template.  The New Project from Template 

window opens listing the available project templates.  

2. Select the desired project template.  

3. Confirm the name and location of the new project, and the data format as shown in 

the window and make changes as needed. 

4. Click OK.   The Form Designer will begin constructing the forms and fields and after 

a few moments, the first page of the project opens in the canvas. 

Create a New Form in an Existing Project 

1. Select File > New Form or right click on the project folder in the Project Explorer 

and select Add Form. The form dialog box opens. 

2. Type a Form Name.  

3. Click OK. The new form appears in the Project Explorer, and the first page appears 

in the canvas area. 

Open an Existing Project 

There are two ways to open an existing project.   

If the project you want to open is one of the four most recent projects opened, select File > 

Recent Projects and select the project from the list. 

Otherwise, follow these steps: 

Click the Open Project button from the toolbar or select File > Open Project.  The Open 

dialog appears 

1. Select a project file (.prj) from the Epi Info™ Projects folder.  
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Note: Epi Info™ will only display files in the Epi Info Project File format (*.prj).  

2. Click Open. The project appears on the canvas. 

 

Close Project 

1. Click the Close Project button from the toolbar or select File > Close Project. 

2. The project closes. 

Note: Epi Info™ automatically saves all changes to the project.  

There is no save function in Form Designer. 

Add or Insert a Page 

Add a Page 

The Add Page function will add a blank page at the end of the form. To add a page, right 

click on the form in the Project Explorer and select Add Page from context menu or select 

Insert > Page > Add Page from the toolbar. 

 

Figure Error! No text of specified style in document..13: Add a Page 

Enter a page name in the Set Page Name dialog box and click OK. The blank page 

appears on the canvas and in the Project Explorer at the end of the form. 

 
Figure Error! No text of specified style in document..14: Set Page Name 
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Insert Page 

The Insert Page function will add a blank page immediately before the current page 

displayed on the canvas. To insert a page, right click on the desired page in the Project 

Explorer and select Insert Page from the context menu or select Insert > Page > Insert 

Page from the toolbar 

 

Figure Error! No text of specified style in document..15: Insert Page 

 

The new page appears on the canvas and in the Project Explorer immediately before the 

current page. 

Name a Page 

1. Right click on a page in the Project Explorer. Select Rename Page from the context 

menu.  

 
Figure Error! No text of specified style in document..16: Rename Page 

2. The Page Name dialog box opens. Enter a name in the Page Name field. 
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Figure Error! No text of specified style in document..17: Set Page Name 

3. Click OK. The page name appears in the list of pages. 

 

Delete a Page 

From the Project Explorer, right click on the page you want to delete and select Delete 

Page or select Edit > Delete Page from the toolbar. 

 

Figure Error! No text of specified style in document..18: Delete Page 

Note: If there is only one page to the form, then you cannot delete the only page. 
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Figure Error! No text of specified style in document..19: Primary Page cannot be Deleted 

Otherwise, a dialog box opens prompting you to confirm deletion. Click Yes. The page is 

deleted. 

 
Figure Error! No text of specified style in document..20: Delete Page Confirmation dialog box 

Undo / Redo 

Most actions performed on the canvas, such as moving fields, copying and pasting fields, 

and changing field alignment, are recorded in the memory of the tool. This allows you to 

undo any of those actions.  

Click Undo from the toolbar or Ctrl + Z to undo the most recent action in the list. Form 

Designer begins recording actions when it is opened. Therefore, you can undo all actions 

from the most recent to the first action performed since opening Form Designer. 

Click Redo from the toolbar or Ctrl + Y to redo the most recent action undone.  As with 

Undo, the Form Designer remembers the actions retracted by clicking Undo. Therefore you 

can Click Redo repeatedly to reinstate the actions retracted by Undo, up to the first time 

Undo was clicked.  
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Form Designer only remembers actions in the Redo list that were undone by clicking Undo. 

As soon as you make any other changes directly to the canvas, other than clicking Undo, 

then the Redo list is discarded.  Redo can only reinstate actions that were undone—it 

cannot be used to repeat actions made directly to the canvas. 

Check Code 

Epi Info™ allows the creator of the questionnaire or survey to guide the data entry process 

to produce range checking, automatic skip patterns and coding of variables. This is 

accomplished using Check Code. Many other more complex functions are possible such as 

mathematical or logical operations, checking the value of a field against the value of one or 

more other fields, and displaying helpful dialogs or custom error messages. Click the 

Check Code button to open the Check Code Editor. For information about the Check Code 

Editor, refer to the Check Code section of the user guide. 

Enter Data 

The Enter tool is used to enter data into the data entry forms in Epi Info™ 7. Click the 

Enter Data button to open the current form in the Enter tool. Only independent, stand-

alone forms or Parent level forms can be opened in Enter. If the form is a Related Form—as 

in a child form related to another parent form—then you cannot open the Related Form by 

clicking the Enter Data button. You must open the top-most parent form first, and then use 

the parent form’s relate button to access the child form. This is required in order to keep 

the record hierarchy according to the related table relationship.  

If a form does not yet contain a data table, Epi Info™ will prompt you to create a data table 

in this step. For information regarding the Enter tool, refer to the Enter Data section of the 

user guide. 

 

Fields 

 

A Field is sometimes called a data entry field or input field.  The field is usually where the 

answers to the questions are entered, although Epi Info™ 7 has a few field types that don’t 

receive any data such as Label Fields and Command Buttons.   

Fields usually contain a question or prompt or some text describing the data that will be 

collected. In Epi Info™ 7, different fields are provided to collect different types of 

information.  A list of available fields is shown in the Project Explorer under the Fields 

category or when you right click on the Canvas and select New Field. 
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Figure Error! No text of specified style in document..21: New Field context menu 

Field Attributes 

Fields have properties or attributes that help control how or if they receive data. Each field 

type has a set of available field attributes; however, some options may not be shown or may 

be disabled (grayed out) depending on the field type selected.  

 Required field attribute makes a field mandatory in data entry. If a page contains 

fields marked with the Required attribute, the Enter tool will not allow record 

navigation or the saving of a partially completed record until a value is supplied in 

all Required fields.   

Use With Caution!  The Required attribute can potentially cause gridlock if, for 

any reason, the required information is not available at the time of data entry.   

It is best to use this attribute sparingly to avoid this situation.   

Additionally, Check Code can be used to set or unset a field’s required status.  For 

more information on this feature, refer to the topics in the Check Code Command 

Reference on the SET-REQUIRED and SET-NOT-REQUIRED commands. 
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 Read Only – prevents data entry into the field.  This attribute is used for fields that 

hold calculated or prepopulated values that should not be edited.  The cursor cannot 

be placed in the field and therefore no data entry can occur.  Also, since the cursor 

cannot enter a field with this attribute, Check Code written for this field will not 

have a chance to run. 

 

The Read Only attribute is useful for calculated fields that will not be changed 

directly. Read Only cannot be used in combination with the Required attribute 

because those attributes are mutually exclusive. 

 Retain Image Size – used only for image fields, this attribute maintains the size of 

the original image and does not alter the size to fit the image box in the form. 

 Range – enables a valid range with lower and upper limit fields.  Only Number and 

Date field types can have range values. If a value is entered that is less than the 

lower limit or greater than the upper limit, you will get a warning message. Missing 

values are accepted unless the field’s Required attribute is checked. 

 Repeat Last – causes the field to be automatically populated with the last value 

displayed for that field.  This may speed up data entry for fields that often have a 

value the same as the last record entered.  For example, if entering many records 

from a given clinic, then a “Clinic Name” field could have the Repeat Last attribute 

checked so it will be automatically filled in from the clinic name used in the last 

record. 

 Pattern – the format that a response must be entered in the field.  

 Prompt Font -- the font for the text entered in the Question or Prompt text box. 

 Field Font -- the font for the data entered into the field. 

 
Figure Error! No text of specified style in document..22: Font dialog box 
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Field Type Required Read 

Only 

Retain 

Image 

Size 

Range Repeat 

Last 

Pattern Web Survey 

Compatible 

Companion 

for Mobile 

Compatible 

Label/Title       X X 

Text X X   X  X X 

Test 

(Uppercase) 
X X   X   X 

Multiline X X   X  X X 

Unique 

Identifier 
        

Number X X  X X X X X 

Phone 

Number 
X X   X X   

Date X X  X X  X X 

Time X X   X  X X 

Date-Time X X   X    

Checkbox  X   X  X X 

Yes-No X X   X  X X 

Option       X X 

Command 

Button 
       X 

Image   X     X 

Mirror         

Grids         

Legal 

Values 
X X   X  X X 

Comment 

Legal 
X X   X  X X 

Codes X X   X    

Relate         

Group       X X 
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Figure Error! No text of specified style in document..23: Field Attributes 

Add a New Field 

Click and drag the type of field you want to add from the Project Explorer to the 

approximate location on the canvas.  

Alternatively, right click on the canvas in the approximate location you want to add a field 

and select the field type from the New Field context menu.  

A Field Definition dialog box appears. The contents of the Field Definition dialog depend 

on the type of field being added.   

Label/Title 

The Label/Title field allows you to have a title on the form or to give instructions or other 

information. Since this field type does not allow any data entry, it does not have Check 

Code, and is not searchable. The following figure is an example of a Label/Title field in 

Enter (circled in blue) based on the FoodHistory form of the sample EColi project. 

 
Figure Error! No text of specified style in document..24: Label/Title Field 

To complete the Label/Title Field Definition dialog: 

1. Enter the Question or Prompt. The text entered in this field will display on the 

canvas.  

2. Click in the Field Name text box. Epi Info automatically suggests a field name 

based on the Question or Prompt, however, it is very important that field names be 

short, intuitive, and usable.  The field name is used for data validation in Check 

Code and when doing analyses.   Field names cannot start with a number or contain 

any spaces or non-alphanumeric characters (except the underscore character “_” is 

permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

3. Click the Font button to adjust the Question or Prompt font settings. Titles 

typically are configured with larger font or bolder text. 



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-25 

 

  
Figure Error! No text of specified style in document..25: Label/Title Field Definition dialog box 

4. Click OK. The Label/Title appears on the canvas. 

Text Field 

The Text field is one of the most generic and common data entry fields used to capture text 

type data—letters, numbers, and symbols. Text fields hold up to 255 characters in a single 

line. You can restrict the number of characters entered by specifying a maximum field size. 

Text fields are often used for short questions such as name, address, occupation. The 

following figure provides an example of how a Text field appears in Enter (circled in blue) 

based on the FoodHistory form of the EColi project. 



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-26 

 

 
Figure Error! No text of specified style in document..26: Text field 

To complete the Text Field Definition dialog box: 

1. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

2. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

3. Optionally, you can limit how long the value can be typed into this field by 

specifying the maximum number of characters using a number (e.g. 10 for ten 

characters).  If the maximum number of characters box is left blank, text fields can 

accept up to 255 characters. 

Note: Entering a maximum number of characters is optional. 
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Figure Error! No text of specified style in document..27: Text Field Definition dialog box 

4. Click OK. The Text field appears on the canvas. 

Text Uppercase 

The Text Uppercase field is used to help standardize the data entered. All letters typed in 

this field are automatically in ALL CAPS. This field draws emphasis to the information 

collected on the form. This field type is not supported on web surveys. The following figure 

provides an example of how a Text Uppercase field appears in Enter (circled in blue) based 

on the Surveillance form of the Sample project. 

 
Figure Error! No text of specified style in document..28: Text (Uppercase) field 

To complete the Text Uppercase Field Definition dialog box: 

1. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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2. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

3. Optionally, you can limit how long the value can be typed into this field by 

specifying the maximum number of characters using a number (e.g. 10 for ten 

characters).  If the maximum number of characters box is left blank, text fields can 

accept up to 255 characters. 

 
Figure Error! No text of specified style in document..29: Text (Uppercase) Field Definition dialog box 

4. Click OK. The Text Uppercase field appears on the canvas. 
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Multiline 

The Multiline field is similar to the Text field but allows for several lines of text. This field 

type allows you to enter a large amount of text based on the question or prompt. The benefit 

of using this type of field is that a Multiline field can hold up to 1 gigabyte of data or 

approximately two million characters. However, you can’t specify the maximum number of 

characters that can be entered into a Multiline field the way you can with a Text field. Also, 

some analyses are more difficult with Multiline data. For example, you can't sort data 

based on values in a Multiline field, so if sorting is important for your work, may be better 

to use another type of field.  Multiline fields are most useful when capturing lengthy 

narratives and wordy, free-form, and descriptive data. The following figure provides an 

example of how a Multiline field appears in Enter (circled in blue) based on the 

Surveillance form of the Sample project. 

 
Figure Error! No text of specified style in document..30: Multiline field 

To add a Multiline field: 

1. Open the Multiline Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

 
Figure Error! No text of specified style in document..31: Multiline Field Definition dialog box 

4. Click OK. The Multiline field appears on the canvas. 

Number 

The Number field only accepts numeric values. Letters and most symbols cannot be 

entered into this type of field, however the negative sign (-) and the decimal point (.) are 

allowed. Number fields can have a valid upper and lower range. For numbers that must 

have a specific number of decimals, you can specify a required pattern. For example, if your 

data requires two decimal places, your number field could have the pattern “##.##” which 

would allow a number between -9.99 to 99.99.  

Note: The negative sign takes one of the pattern spaces.  

Therefore, the number “-7” entered into a field with this pattern would appear as “-7.00”, 

whereas the number “5” would appear as “05.00”. The leading zeros are not included in 

calculations, analyses, or output. The following figure provides an example of how a 

Number field appears in Enter (circled in blue) based on the FoodHistory form of the EColi 

project. 
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Figure Error! No text of specified style in document..32: Number field 

To add a Number field: 

1. Open the Number Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. Optionally, select a pattern from the Pattern drop-down list (optional). You can also 

create a new pattern by typing in the desired pattern using the # symbol and the 

decimal point as needed. The default setting is None. 

5. To limit the range of responses, check the Range checkbox (optional). Type a lower 

and upper limit in the Lower and Upper fields. 
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Figure Error! No text of specified style in document..33: Number Field Definition dialog box 

6. Click OK. The Number field appears on the canvas. 

Phone Number 

The Phone Number field is similar to a number field, but with a pre-defined list of 

common phone number patterns. As with the Number field, letters and most symbols are 

not allowed. This field type is not supported on Web Survey. The following figure provides 

an example of how a Phone Number field appears in Enter (circled in blue) based on the 

Case Report form of the Lyme project. 

 

Figure Error! No text of specified style in document..34: Phone Number field 

To add a Phone Number field: 

1. Open the Phone Number Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. Optionally, select a pattern from the Pattern drop-down list. The default setting is 

None. 

 
Figure Error! No text of specified style in document..35: Phone Number Field Definition dialog box 

5. Click OK. The Phone Number field appears on the canvas. 

Date 

The Date field is used to enter a date. The date pattern for data entry is determined by the 

computer’s regional settings where the pattern can be modified. The date pattern cannot be 

changed within Epi Info™ 7. The following figure provides an example of how Date fields 

appear in Enter (circled in blue) based on the FoodHistory form of the EColi project. 
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Figure Error! No text of specified style in document..36: Date field 

To add a Date field: 

1. Open the Date Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. To limit the range of responses, check the Range checkbox (optional). Enter a lower 

and upper date range into the Lower and Upper fields or select a date using the date 

calendar by clicking on the calendar icon. 
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Figure Error! No text of specified style in document..37: Date Field Definition dialog box 

5. Click OK. The Date field appears on the canvas. 

Time 

The Time field is used to collect time data in the form of hours, minutes, seconds, and AM 

or PM.  The time pattern for data entry is determined by the computer’s regional settings 

where the pattern can be modified. The time pattern cannot be changed within Epi Info™ 

7. 

To add a Time field: 

1. Open the Time Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

 
Figure Error! No text of specified style in document..38: Time Field Definition dialog box 

4. Click OK. The Time field appears on the canvas. 

Date-Time 

The Date-Time field is used to collect data representing the exact date and time of a given 

moment. It is like a date field combined with a time field. The Date-Time pattern for data 

entry is determined by the computer’s regional settings where the pattern can be changed, 

if needed. The date-time pattern cannot be changed within Epi Info™ 7. This field type is 

not supported on Web Survey. The following figure provides an example of how a Date-

Time field appears in Enter (circled in blue) based on the Oswego form of the Sample 

project. 
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Figure Error! No text of specified style in document..39: Date-Time field 

To add a Date-Time field: 

1. Open the Date-Time Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very important 

that field names be short, intuitive, and usable.  The field name is used for data 

validation in Check Code and when doing analyses.   Field names cannot start with a 

number or contain any spaces or non-alphanumeric characters (except the 

underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot be 

changed after data collection starts. 

 

 
Figure Error! No text of specified style in document..40: Date-Time Field Definition dialog box 
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4. Click OK. The Date-Time field appears on the canvas. 

Checkbox 

The Checkbox field allows you to collect data by checking or unchecking a box. Multiple 

checkboxes can be used to quickly enter responses that are consistent in the study (e.g. 

symptoms or foods eaten). Checkbox fields collect binary data such as 0 or 1, True or False, 

Yes or No. The response is stored in the database as a 1 or 0 where 1 equals Yes and 0 

equals No. When writing Check Code, use (+) and (–) to indicate yes and no, respectively. 

Unlike the Yes-No field type, Checkbox fields do not contain missing values, so all 

checkbox fields are considered to be “No” until they are checked during data entry or 

assigned a “Yes” value in Check Code. Since checkbox fields can only be either Yes or No, 

these fields cannot be required fields. The following figure provides an example of how 

Checkbox fields appear in Enter (circled in blue) based on the FoodHistory form of the 

EColi project. 

 
Figure Error! No text of specified style in document..41: Checkbox field 

To add a Checkbox field: 

1. Open the Checkbox Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 
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Figure Error! No text of specified style in document..42: Check Box Field Definition dialog box 

4. Click OK. The Checkbox field appears on the canvas. 

Yes-No 

The Yes-No field is used to collect data with only a Yes or No answer. The field appears as 

a drop-down list on the canvas. The answer is stored in a database as a 1 or 0 where 1 = Yes 

and 0 = No. When writing Check Code, use (+) and (–) to indicate yes and no, respectively. 

Until this field is answered one way or the other, the field’s value is considered to be 

missing.  In Check Code, the missing condition is indicated by the (.) operator. The 

following figure provides an example of how a Yes-No field appears in Enter (circled in 

blue) based on the FoodHistory form of the EColi project. 

 
Figure Error! No text of specified style in document..43: Yes-No field 
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In the Enter module and in the output of analyses, the values for Yes-No fields can be 

displayed in a variety of ways, or customized for a specific purpose such as in translation to 

another language.  Regardless of how the data are displayed, the values in the database 

and in exported output are still only 1 or 0.   

 

Yes-No fields can display 

their data as: 

  

Yes No Missing 

True False Unknown 

(+) (-) (.) 

<custom setting> <custom setting> <custom setting> 

To add a Yes-No field: 

1. Open the Yes-No Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 
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Figure Error! No text of specified style in document..44: Yes-No Field Definition dialog box 

4. Click OK. The Yes-No field appears on the canvas. 

Option 

The Option field creates a group box containing mutually exclusive option buttons, also 

known as radio buttons. These are used for fields requiring one and only one answer. When 

a choice is made, any other selection within the group is cleared. In the database, the 

values are stored as a zero-based array. The first option is 0, the second is 1, the third is 2, 

and so on. The image below shows an example of two option fields.  Since the options are 

mutually exclusive, in the first example you can’t select both options “Have your cake” and 

“Eat your cake”.  You may select only one or the other.  The field name for this example 

option field is “HaveOrEatCake”.  Since the first option is selected, the field 

“HaveOrEatCake” has the value of zero (0). In the next example, the field name is 

“TrafficLightColor”.  Since the selected color is the third option, the value of 

“TrafficLightColor” is two (2). 
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Figure Error! No text of specified style in document..45: Option Field 

To add an Option field: 

1. Open the Option Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. Select Vertical or Horizontal from the List options vertically or horizontally 

field to choose how the options are displayed in the Option field. 

5. In the Start listing options on the left or right field, select Left or Right to 

choose where the options are listed. 

6. In the Attributes field, select Right or Left to determine how the radio buttons are 

aligned with the option text. 

7. Select the Number of Choices in the Attributes field. You can have a maximum of 

16 options. The number of options selected corresponds to the number of rows listed 

under Option Definition. 

8. Enter the option name in each row of the Option Definition section. 
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Figure Error! No text of specified style in document..46: Option Field Definition dialog box 

9. Click OK. The Option field appears on the canvas. 

Command Button 

The Command Button creates a clickable button on the form and is used to run a specific 

block of Check Code. Below are a few examples of the possible applications of a Command 

Button and the Check Code behind the button: 

 Compare the values of fields and perform automatic calculations 

 Raise a message for information or to alert the data entry person to invalid data 

 Capture longitude and latitude coordinates from an address field 

 Run a prewritten program in Classic Analysis 

 Open the Visual Dashboard with a saved canvas 

 Open other programs outside of Epi Info™ 7 such as Microsoft Excel or Outlook. 

The Command Button field is not supported on Web Survey.  The following figure provides 

an example of how a Command Button appears in Enter (circled in blue) based on the 

FoodHistory form of the EColi project. 
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Figure Error! No text of specified style in document..47: Command Button 

To add a Command Button field: 

1. Open the Command Button Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 
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Figure Error! No text of specified style in document..48: Command Button Field Definition dialog box 

4. Click OK. The Command Button field appears on the canvas. 

Image 

The Image field allows an image to be inserted in the record. Examples of items that could 

be included as an image might be the patient’s photo, an image of a wound, rash or insect 

bite, a bacteria culture dish, or the barcode of a sample vial. This is especially useful when 

the data collection device has a built in camera such as a tablet computer and smart phone. 

If the image is not collected from a built in camera, clicking in this field will display the 

Open dialog to browse for an image file. The accepted image file types are: Portable 

Network Graphics (.PNG), Graphics Interchange Format (.GIF), Joint Photographic Expert 

Group (.JPG or .JPEG), and Windows Bitmap Format (.BMP). This field type is not 

supported on Web Survey. 

 
Figure Error! No text of specified style in document..49: Image field 
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To add an Image field: 

1. Open the Image Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. By default, Epi Info™ expands/contracts the image to fit in the size of the Image 

field. Check the Retain Image Size checkbox to disable this function and have the 

image inserted in the field without modification.  

 
Figure Error! No text of specified style in document..50: Image Field Definition dialog box 

5. Click OK. The Image field appears on the canvas. 

Mirror 

The Mirror field shows data in a field on another page. It does not actually store data of its 

own. It only shows data from another field.  This is useful when the same information needs 

to be displayed on multiple pages in a form.  Since this field type does not allow any data 

entry, it does not have a column in the database, Check Code cannot be run on this field, 

and Mirror fields are not searchable.  This field type is not supported on Web Survey. 
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Mirror fields also have the following attributes: 

 Mirror fields are Read Only. 

 When the source field receives data through data entry or when it is assigned a 

value in Check Code, the value of that field will be reflected in the Mirror field. 

 Mirror fields can be copied and pasted to subsequent pages while in the Form 

Designer.  However, since they are Read Only, their contents cannot be copied 

when running the form in the Enter tool. 

 Command buttons cannot be selected as source fields to mirror. 

The following figure is an example showing three mirror fields on Page 2 of a form that 

reflect the data entered into Page 1 of the form.  The mirror fields on Page 2 are circled in 

blue. 

  
 

Figure Error! No text of specified style in document..51: Mirror fields reflecting data entered on Page 1 

To add a Mirror field: 
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1. Open the Mirror Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for hiding or unhiding mirror fields in Check Code and other commands.   Field 

names cannot start with a number or contain any spaces or non-alphanumeric 

characters (except the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. Click the Assigned Variable drop-down list in the Attributes Group to show a list 

of variables that can be mirrored. 

5. Select the variable to be mirrored. 

 
Figure Error! No text of specified style in document..52: Mirror Field Definition dialog box 

6. Click OK. The Mirror field appears on the canvas. 

 

Grid 

The Grid field allows users to enter data in the form of a spreadsheet on the page. This 

allows for simple and effective data entry for multiple data points.  
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When you create a Grid field, you specify each column for the grid, the type of data for the 

column, its size and properties.   

 

Figure Error! No text of specified style in document..53a: Grid Field 

Before deciding to use a Grid field on your form, please also know the following limitations 

with Grid fields: 

1. Not all field types are supported as grid columns.  Text, Number, Date, Time, Date-

Time, Phone Number, Checkbox, Yes-No, Legal Value, and Comment Legal field 

types are supported. 

2. Grid fields do not support Check Code.  This means that the many things that Check 

Code can offer, such as automatic calculations, skip patterns, enabling/disabling of 

fields, or other data entry validation, are not available to Grid fields. 

3. Grid column tab order cannot be changed.  Pressing the tab key moves the cursor to 

the next field from left to right.  Pressing the Enter key moves the cursor within the 

same column, but down to the next row. 

4. Grid fields are not supported on Web Survey. 

 

To add a Grid field: 

1. Open the Grids Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

 
Figure Error! No text of specified style in document..54: Grids Field Definition dialog box 

After setting the Question or Prompt for the Grid field and setting it’s Field Name, 

the Add button is enabled. 

4. Click the Add button. 
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Figure Error! No text of specified style in document..55: Grid Columns 

5. Type the column heading into the Enter Column Name for Grid textbox. This 

text will display as the column heading on the form. 

6. Press Tab or click in the Column Name textbox. Epi Info automatically suggests a 

column name based on the Enter Column name for Grid field, however, it is very 

important that column names be short, intuitive, and usable. The column name 

cannot start with a number or contain any spaces or non-alphanumeric characters 

(except the underscore character “_” is permitted). 

Note:  It is best to simplify the column name at this time.  Column names 

cannot be changed after data collection starts. 

7. Select the column size from the Size drop-down list. This determines the amount of 

characters that can be placed in that column’s cells.  This setting only applies to 

Text type columns. 

8. Select the column format from the Column Type drop-down list. Available formats 

are: 
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Figure Error! No text of specified style in document..56: Grid Column Types 

9. After selecting a Legal Values or Comment Legal column type, click the browse 

button next to the Data Source field and complete the steps outlined in the Legal 

Values and Comment Legal field sections below. 

10. Click Save Column to add the column to the grid.  

11. Repeat steps 5-10 until all desired columns have been added. 

12. Click OK. The Grid field appears on the canvas. 

 

Legal Values 

A Legal Values field creates a drop-down list of choices on the field. The responses listed in 

the drop-down are the only choices available to the respondent and cannot be altered. The 

following figure provides an example of how Legal Value fields appear in Enter (circled in 

blue) based on the Surveillance form of the Sample project. 
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Figure Error! No text of specified style in document..57: Legal Values field 

To add a Legal Values field: 

1. Open the Legal Values Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 
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Figure Error! No text of specified style in document..58: Legal Values Field Definition dialog box 

4. Click the Browse button to the right of the Data Source textbox. 

5. Click Create New to enter the available answers for the question.  

 
Figure Error! No text of specified style in document..59: Set Up Code / Legal Links 
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6. Enter the first value (e.g. Years). Press Enter or Tab to advance to the next value. 

7. Enter additional values until all necessary items are added to the drop-down list. 

8. Values will appear in alphabetical order unless you select Do Not Sort. This feature 

displays values in the order in which they were entered.  

9. Click OK. 

10. Existing tables can also be used to create legal values. 

1. Click Create New from existing (takes a copy of selected table, changes to 

the original table will not affect the new table) or Use Existing (establishes 

a connection between the selected table and the new table, any changes made 

to the original table will modify the new table) 

2. Select a table from the drop-down list.  

3. Click OK. 

11. From the Field Definition box, click OK. The new field appears in the form as a 

drop-down list of values. 

Comment Legal 

Comment Legal fields are similar to Legal Values. They are text fields with character(s) 

typed in front of the text (with a hyphen). During data entry, the character and the text 

(e.g., M-Male) are displayed. However, only the character value is stored in the table (e.g., 

M). In the Classic Analysis and Visual Dashboard tools, statistics can be calculated if all 

values are numeric. The following figure provides an example of how a Comment Legal field 

appears in Enter (circled in blue) based on the CaseReport form of the Lyme project. 

 

Figure Error! No text of specified style in document..60: Comment Legal field 

To add a Comment Legal field: 

1. Open the Comment Legal Values Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

 
Figure Error! No text of specified style in document..61: Comment Legal Field Definition dialog box 

4. Click the browse button to the right of the Data Source textbox. 

5. Click Create New to enter the available answers for the question.  
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Figure Error! No text of specified style in document..62: Set Up Code / Legal Links 

6. Enter the first value using the form code-hyphen-comment as in "M-Male" where 

"M" is the code and "Male" is the comment.  Press Enter or Tab to advance to the 

next value. 

7. Enter additional values using the same code-hyphen-comment format until all 

necessary items are added to the drop-down list. 

8. Values will appear in alphabetical order unless you select Do Not Sort which will 

display values in the order in which they are entered.  

9. Click OK.  

10. Existing tables can also be used to create comment legal fields. 

1. Click Create New from existing (takes a copy of selected table, changes to 

the original table will not affect the new table) or Use Existing (establishes 

a connection between the field and the existing table. Any changes made to 

the original table will be seen in all fields that use this table as the source.  

2. Select a table from the drop-down list.  

3. Click OK. 
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11. From the Field Definition box, click OK. The new field appears in the form as a 

drop-down list of values. 

Codes 

A Codes field designates the available options on a form based on the user’s response to a 

question. Based on the value selected from a drop-down list, other field(s) are populated 

with predetermined values. At least two fields must exist; one which holds the selection 

code, and another to receive the value of the code. The first field holds the selection code in 

a drop-down list while subsequent fields are Read Only and are populated based on the 

values in the code table. The Codes field allows for more efficient data entry by the user.  

This field type is not supported on Web Survey.  The following figure provides an example 

of how a Codes field appears in Enter (circled in blue) based on the Surveillance form of the 

Sample project. 

 
Figure Error! No text of specified style in document..63: Codes field 

Create a New Code Table 

1. Open the Codes Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

4. Select the field(s) to be linked from the Select field(s) to be linked section. To 

select multiple fields, hold down the CTRL key and click each field. 
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Figure Error! No text of specified style in document..64: Codes Field Definition dialog box 

5. Click on the Data Source Browse button. 

 

Figure Error! No text of specified style in document..64 b:Create New Code table 
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6. Click Create New. A spreadsheet opens for you to enter the values for the Codes 

field and Linked fields. 

 

Figure Error! No text of specified style in document..65: Codes Data Source Blank 

7. The left-most column displays the selection field(s) chosen in the Fields Definition 

dialog box.  

 
Figure Error! No text of specified style in document..66: Codes Data Source Complete 
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8. Each column to the right lists the field(s) to receive the codes based on the value of 

the selection field. 

9. Enter the codes for each field.  

10. Press the Tab key to move to the next field, or to the next row if at the end of a row. 

11. Click OK to accept the codes for each field. 

12. Existing tables can also be used to create code tables. 

1. Click Create New from Existing (takes a copy of the selected table, 

changes to the original table will not affect the new table) or Use Existing 

(establishes a connection between the selected table and the new table, any 

changes made to the original table will modify the new table) 

2. Select a table from the drop-down list.  

3. Click OK. 

13. Click OK to close the Field Definition dialog box and place the fields in the form. 

14. To test the code table, open the Enter tool and verify that both fields populate based 

on the drop-down list selection. 

 

Create Cascading Drop-Down Fields 

Cascading Drop-Down fields are essentially two or more Code, Legal Value, or Comment 

Legal fields linked together in such a way as to filter each subsequent field based on the 

value selected in prior fields.  In the example described below, the drop-down field for State, 

filters the drop-down field, County, to show only those counties that exist in the selected 

State.  When County is selected, the drop-down field for Hospital is shown with only the 

hospitals located in the selected county. 

In order to create Cascading Drop-Down fields, you need to have a table completed with all 

values for the linked fields that can be imported into Epi Info™ 7.  The Excel spreadsheet 

shown below, named ‘codeHospital’, is an example of such a table.  When importing this 

table into your Epi Info™ 7 project, the table name must contain the prefix “code”, as in this 

example, “codeHospital”. 
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Figure Error! No text of specified style in document..67: Cascading Drop-down Fields 

 

To add Cascading Drop-down fields, complete the following steps: 
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1. Add the first Codes field to the page, but don’t link the field to other fields, yet. You 

will do this in later steps.   For this example, we named the field StateName.  

 

 

Figure Error! No text of specified style in document..68: Adding Codes to Cascading Drop-down Fields 

2. Add another Codes field to the page.  Again, don’t link the field to other fields, yet.  

In this example, we named the second field County.  Repeat this step for all but the 

last field in your cascading sequence.  In this example, we have only three fields to 

link, so the next field will be our last. 
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3. Add the last field in our cascading sequence.  The last field should be a type other 

than a Codes field, such as Legal Value or Comment Legal.  Since no other fields will 

be linked to this last field, you don’t want to use a Codes field.   In our example, we 

have two Codes fields named ‘StateName’ and ‘County’, and one Legal Value field 

named ‘Hospital’. 

 

 

Figure Error! No text of specified style in document..69: Adding Legal Values to Cascading Drop-down Fields 

4. If using a Legal Value or Comment Legal field for the last field, click the browse 

button to the right of Data Source.  The Set Up Code / Legal Links dialog opens. 

5. Click Use Existing. The Open Form – Select a Table dialog box opens. 
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6. Select the code table that was imported and click OK.  In this example, we selected 

the codeHospital table. 

 

 

Figure Error! No text of specified style in document..70: Open Form Dialog Box 

7. Click OK.  The Select a field dialog opens showing the columns in the codeHospital 

table that can be linked.  
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8. Select the appropriate field.  Because we are linking the Hospital field, we selected 

Hospital in this example. 

 

Figure Error! No text of specified style in document..71: Selecting a Field 

9. Click OK on the Select a Field dialog.  The Set Up Code / Legal Links data source 

table shows the values from the Hospital column in table. 

 

Figure Error! No text of specified style in document..72a: Data Source shows values for Hospital 

10. Click OK on the Set Up Code / Legal Links dialog box. 
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11. Click OK on the field definition dialog.  The next steps are to link the fields to the 

remaining Codes fields. 

12. Open the properties for the first Codes field added above.  (Right click the field and 

select Properties.)  Our first field was ‘StateName’ and we want to link this field to 

the County field so when the State Name is selected, only the corresponding counties 

are shown in the County field. 

13. In the Select Fields to be Linked box, select the field you want to be filtered.  

Since, in our example, we want the County field to be filtered based on the selection 

made for State, we should select County here. 

14. Click the Browse button to the right of Data Source.  The Codes dialog opens.  

15. Click Use Existing.  The Select a Table dialog box opens. 

16. Select the same code table used to link the last field.  In our example, codeHospital 

is the code table we are using. 

17. Click Link.  The Match Fields dialog box opens.  This is where we match the fields 

in our cascading sequence to the columns in the code table. 

18. Select the column to be linked to the first Codes field.  Since our first field is 

StateName, we selected the column from our imported table named ‘State’. 

19. In the Link Associated Fields group, select the Form Field to be linked.  For 

our example we want County to be linked to State, so we selected County. 

20. In the Table Fields drop-down, select the corresponding column in the code table. 

21. Click Link.  The association to the linked field appears in the Linked Fields box. 

 

Figure Error! No text of specified style in document..73: Match Fields Dialog Box 
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22. Click OK to close the Match Fields dialog. 

23. Repeat the steps 12 through 21 for each remaining Codes field in the cascading 

sequence.  For each, specify the next field in the cascading sequence and link it to 

the corresponding field in the code table.  In our example, County is the only 

remaining Codes field to be linked and this field will be linked to Hospital.  

 

Figure Error! No text of specified style in document..74: Linked Fields 

This completes the process to create a series of cascading drop-down fields.  When the form 

is opened in Enter, the selection made in the first field in the cascading sequence will filter 

the values shown in the next field in the sequence.  In our example, when Florida is 

selected for State Name, the list shown for County only includes the values Alchua, Baker, 

Escambia, and Miami-Dade. 
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Figure Error! No text of specified style in document..74: State Name field now filters the values shown for the 

County field 

 

The StateName codes field filters the County codes field because of they way they are 

linked and because Alchua, Baker, Escambia, and Miami-Dade are the only counties on the 

same rows as Florida in the codeHospital table.   

 

Figure Error! No text of specified style in document..755: The codeHosptal table imported from Excel. 

Likewise, when the county Alchua is selected, only the values Alchua-Hosp1 and Alchua-

Hosp2 are shown in the Hospital legal values field. 

 

Relate 

Related forms are relationships between the main or parent form with sub or child forms. 

They are used to establish a one-to-one or one-to-many relationship between parent form 

records and child form records.  For example, a survey may have a form devoted to patient 

information.  This may be related to a form to record the many hospital visits that each 

patient may have.  Related forms are linked to a parent form automatically by unique keys 

generated by Epi Info™ 7.  In Enter, the related form is opened by clicking a Related Form  

Button. When a Related Form Button is selected, it will open the first page of the related 

form.  Using Check Code, the Relate Button can be made conditionally accessible (e.g., to 

show a special form for a particular disease). This field type is not supported on Web 

Survey or on the Companion for Android application. The following figure is an example of 

how a Relate field appears in Enter (circled in blue) based on the Surveillance form of the 

Sample project. 
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Figure Error! No text of specified style in document..76: Relate field 

To add a Relate field: 

1. Open the Relate Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 
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Figure Error! No text of specified style in document..77: Relate Form Button Field Definition dialog box 

4. From the Related Form drop-down list, select Create new form to create a new 

form or select an existing form.  

 The dialog box will show the Accessible always button selected. This option 

cannot be modified. The Accessible only when following conditions are 

true selection is not available in this version of Epi Info™ 7. 

 Accessible always will create a related button in the form that is active at all 

times during data entry.  

 Accessible only when following conditions are true will be available in a 

future Epi Info™ release. However, a conditional statement can be created using 

Check Code (see Check Code). Check Code can be associated with the button to 

create a condition statement.  

5. Select ‘Return to the parent form after one record has been entered’ to allow 

only one record to be entered in the related form for each record in the parent form.  

In Enter, after a record is saved in the related form, you are returned to the parent 

form. If multiple entries are desired, then leave this option unselected. 

6. Click OK. The Related Form button appears on the canvas. 
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Group 

A Group field is a way to group together one or more fields on a page for visual and 

practical purposes.  Visually, a group helps to tie similar fields together into a common 

category.  Grouped fields also provide organization and structure to the form. A background 

color can be added to a group to enhance its appearance.  You can nest groups and arrange 

them so they overlap specific fields for situations where you need a Venn style “diagram” on 

your form. 

Group fields also have several practical purposes. In Classic Analysis and the Visual 

Dashboard, you can run statistics on individual fields, but if the fields are contained within 

a group, then you can use the group field and the statistics will be done on each field within 

the group.  

Similarly, several Check Code commands can be run on all fields within a group by using 

just the group name, rather than using each field name individually.  This makes 

commands such as Enable, Disable, Clear, Highlight, Set-Required, Set-Not-Required, 

among others, much easier for you to write. 

Fields contained within the Group box are automatically members of the Group field.  To 

remove a field from a group, simply drag the field outside of the boundaries of the group 

box.  Likewise, dragging the group box itself will move all the fields within the group.  

When the group box is released, any additional fields within the boundaries of the group 

box are automatically members of the group field for analyses and Check Code execution. 

The following figure provides an example of how Group field (circled in blue) appear in 

Enter. 
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Figure Error! No text of specified style in document..78: Group field 
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Figure Error! No text of specified style in document..79: Nested Venn-style Group fields 

  

To create a Group field: 

1. Click and drag a rectangle around the fields to be grouped.  Each field in the 

selection appears highlighted with a rectangle. 

2. From the Form Designer toolbar, select Insert > Group or right click on a blank 

part of the canvas and select New Group Field from context menu. The Group 

Properties dialog box appears. 
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Figure Error! No text of specified style in document..80: Group Field Properties 

3. Enter the Question or Prompt. The text entered in this field will display on the 

canvas and prompt the user to enter a response.  

4. Click in the Field Name text box or press the tab key.  Epi Info automatically 

suggests a field name based on the Question or Prompt, however, it is very 

important that field names be short, intuitive, and usable.  The field name is used 

for data validation in Check Code and when doing analyses.   Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters (except 

the underscore character “_” is permitted).  

 

Note:  It is best to simplify the field name at this time.  Field names cannot 

be changed after data collection starts. 

5. Click OK to create the group. The fields appear in the group box. 

 Move the group by clicking and holding the group name with the mouse. 

 Resize the group box by moving the cursor over the group and adjust the box 

dimensions by clicking and dragging the corner boxes to the desired dimensions. 

If the new size includes additional fields, they become members of the group. 

 Fields in the group are rearranged in the same process as on the Form Designer 

canvas. Click on the field and drag the field to the desired location. 
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Edit an Existing Field 

Right click on the field and select Properties from the context menu. The Field Definition 

dialog box appears. Make the necessary changes and click OK.   

Edit a Field Name 

Field Names are critically important to Epi Info™ 7 projects because they are the basis for 

everything from database management, to data validation, and analysis.  Because field 

names are such an integral part of Epi Info™ 7 projects, field names cannot be changed 

after the data table has been created to begin collecting data—even when testing the 

form with test data. 

Therefore, it is very important to establish a concise and usable naming convention for your 

field names when beginning to design your data entry form.  Although Epi Info 

automatically suggests a field name based on the Question or Prompt, it does so by 

concatenating the first several words together, stripping spaces and invalid symbols.  This 

can be convenient when the question is only a few short words, but if the prompts to your 

questions frequently begin with similar phrases such as “Please enter the …?” or “What is 

the …?”, then the suggested field names will also have the same ambiguous start creating a 

very challenging and tedious experience searching for a specific field when writing Check 

Code or using Analysis and the Visual Dashboard. 

For these reasons, is very important that field names be short, intuitive, and usable.  Field 

names cannot start with a number or contain any spaces or non-alphanumeric characters 

(except the underscore character “_” is permitted).  

 

The field name cannot be changed after the data table is created.  When testing a form in 

Enter, the data table is initially created.  If the data table has no data or only test data that 

can be discarded, you can delete the data table in order to change the field name.  Refer to 

the topic ‘Delete an Existing Data Table Without Deleting the Form’ for more 

information. 

Invalid Field Names 

Since field names cannot start with a number, if your question or prompt begins with a 

number, Epi Info’s suggested field name will begin with a leading letter “N” before the 

number.   

Field names cannot have spaces or non-alphanumeric characters other than the underscore.   

Since fields are referenced by their field name in the database, the field name must be 

unique—it cannot already exist as the name of another field in your form.   

Finally, Epi Info needs to reserve some words for internal use and to avoid conflicts related 

to database interaction.  For a complete list of reserved words, please see the appendix  

If your desired field name is invalid for any of the reasons mentioned above, it will appear 

in red font and the OK button will be disabled.  To avoid this, modify the field name 

slightly, perhaps add a suffix or prefix to make it an acceptable name.  Then click OK. 
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Delete a Field 

1. Right click on the field. The context menu opens. 

2. Click Delete. The field is removed from the form. 

Warning: The field and any data previously collected are deleted from the form 

and database. Deletions occur immediately. There is no prompt to verify the 

deletion before it occurs, and the only way to recover the field is by using the 

“undo” feature, however, “undo” will not recover deleted data. 

 

Copy, Cut, and Paste Fields 

1. Click and drag a rectangle around the fields to be copied or cut.  

2. From the Form Designer toolbar, select Edit > Copy or Cut from the drop-down list. 

3. Click in the new section of the form or select a new page in the project. 

4. Select Edit > Paste. The copied fields appear in the form.  

When pasting fields, Epi Info automatically suggests a field name based on the name of 

the original field.  To ensure the field name is unique, Epi Info appends a number.  For 

example, if the field name of a field being copied is “Age”, then the pasted field is 

automatically named “Age1”.  Copying and pasting this field again will result in a third 

field named “Age11”.  The similarity of these names may lead to confusion and 

sometimes errors when used in Check Code and in analyses.  Therefore it is important 

to change the field name as described in the next step. 

5. For each field pasted, do the following: 

1. Right click the new field’s question or prompt and select Properties from the 

context menu. 

2. Click in the Field Name text.  Change the field name making it more clear 

and intuitive for the instance of the new field.   

3. Field names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character “_” is permitted). 

Note:  Field names cannot be changed after a data table has been created (data 

collection has started). 

Note: You can also right click on the field and use the context menu to copy or cut 

the field.  Also, you can right click the canvas and use the context menu to paste a 

field from the clipboard. 
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Align Fields 

There are several ways to align fields in Form Designer. Aligning fields in a consistent 

format allows you to make the form appear more professional. The process of aligning fields 

begins with selecting the desired fields to be aligned. 

1. Click and drag a rectangle around the fields to be aligned. 

 To align the fields vertically, select Format > Alignment > As Stack. 

 To align the fields horizontally, select Format > Alignment > As Table. 

 For additional options, right click on the canvas to display the possible 

alignment configurations. 

 
Figure Error! No text of specified style in document..81: Field Alignment Options 

2. The options appear as follows: 

 Align Selection in Column(s) – aligns all fields vertically in the number of 

columns indicated (similar to Format > Alignment > As Stack). 

 Align Selection on Row – aligns all fields horizontally (similar to Format > 

Alignment > As Table). 

Set Field Size 

There are several field sizing options available in Form Designer. Making field sizes 

consistent will allow you to make the form appear more professional. The process of 

standardizing the field size begins with selecting the desired fields. 

1. Click and drag a rectangle around the fields to be re-sized. 

2. Right click on the canvas to display the possible sizing configurations. 
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Figure Error! No text of specified style in document..82: Adjust Field Size 

3. The options appear as follows: 

 Make Same Width (Use Maximum) – Adjusts selected fields’ width to 

match the widest field of the selection 

 Make Same Width (Use Minimum) – Adjusts selected fields’ width to 

match the narrowest field of the selection 

 Make Same Height (Use Maximum) – Adjusts selected fields’ height to 

match the tallest field  of the selection 

 Make Same Height (Use Minimum) – Adjusts selected fields’ height to 

match the shortest field of the selection 

 Make Same Size (Use Maximum) – Adjusts selected fields’ height and 

width to match the largest field of the selection 

 Make Same Size (Use Minimum) – Adjusts selected fields’ height and 

width to match the smallest field of the selection 

Manually Set Field Size 

1. Hover your mouse over the field to display the field’s frame and sizing handles. 

2. Hover the mouse over one of the sizing handles to see the mouse change to an arrow 

cursor. 

3. Click and drag a sizing handle to stretch the field to the needed size. 
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Figure Error! No text of specified style in document..83: Manually Adjust Field Size 

Manually Set Field Position 

In certain cases, the field alignment or positioning will need to be adjusted manually. In 

Epi Info, the field and prompt can move together or separately. This is especially helpful if 

using a right-to-left language where the question or prompt should be to the right of the 

entry field.   

 

Figure Error! No text of specified style in document..84: Manually Adjust Field Position 
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The following example is based on a form containing a Label/Title field and a Text field. 

 
Figure Error! No text of specified style in document..85: Prompt and Entry Field Selection 

1. To move a field and question together, click and drag the field’s prompt.  

2. To move the field and prompt separately, click and drag the entry field, not the 

prompt, as shown below. 

 
Figure Error! No text of specified style in document..86: Select Entry Field 

3. Release the entry field at the desired location. 
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Figure Error! No text of specified style in document..87: Adjust Entry Field Location 

 
Figure Error! No text of specified style in document..88: Default Prompt Alignment 

4. To restore the original field and prompt alignment according to the default 

configuration, right click on the field or prompt and select Default Prompt Align.  

5. To set the default prompt alignment, select Format > Page Setup from the Form 

Designer menu bar.  Set the default alignment to be vertical so the field is below the 

prompt and left aligned, or horizontal where the field is to the right of the prompt on 

the same row.  
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Figure Error! No text of specified style in document..89: Page Setup dialog showing Default Label-Field 

Alignment 

 

Tab Order 

 

In the Enter module, during data entry, pressing tab or enter will move the cursor to the 

next field.  Tab Order is the order or sequence that the cursor moves from field to field. 

Initially, the tab order is determined by the order in which the fields are added to the form.  

In many cases, as fields are moved around the page, added from a template, or pasted from 

somewhere else, the tab sequence may become disorganized.  There are other situations in 

which you may prefer the tab order to move in a custom way, such as down a column of 

questions, or maybe from right to left across the page. 

The proper tab order will make entering data more user friendly and efficient. Additionally, 

the tab order will determine how fields are displayed on a mobile device.  

To show the tab order, right click on the canvas and select Tabs > Show Tab Order.  The 

tab order number for each field is shown in a rectangle near the entry field.  Red rectangles 
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indicate the field is a Read Only field or one that cannot receive the cursor, such as 

Label/Title fields.  Group fields also do not receive the cursor, but a tab number is reserved 

for the group, even though the tab order number for a Group box is not shown.  

 
Figure Error! No text of specified style in document..90: Show Tab Order 

Start New Tab Order 

Right click the canvas and select Tabs > Start New Tab Order from the context menu. 

Selecting this function will automatically set the tab order according to each field’s position 

from left to right, then top to bottom. 

Customize the Tab Order 

You can customize the tab order to meet the needs of your questionnaire. This process 

begins by showing the tab order on the canvas. The example below demonstrates how to 

adjust the tab order in the Food History form of the EColi project located in the Projects 

folder.  

Right click the canvas and select Tabs > Show Tab Order from the context menu to show 

the current order of field entry. 
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Figure Error! No text of specified style in document..91: Show Tab Order 

In the example shown in the figure above, the sequence will move the cursor from left to 

right, row by row. 

Suppose you wanted to have the order run down the first column, from ‘Fresh celery’ to 

‘Bean sprouts’, then over to the ‘Grapes’ in the second column. There are a couple of 

methods to do this.  

Customize Tab Order using the Mouse 

1. With the Tab Order showing, hover the mouse pointer over the field you want to be the 

first field in the sequence.  In this example, we want to start the sequence with ‘Fresh 

celery’ at tab order 3.  A prompt appears showing the options available to reset the tab 

order. 

 
Figure Error! No text of specified style in document..92: Tab Order Prompt 

 

2. Click on the tab order number to set the index.   In this example, we click the 

number 3 in order to set the index at 3. 

3. Click on the tab order number for the next field you want to follow the index field.  In 

our example, the field below ‘Fresh celery’ is ‘Skim milk’, currently tab order 6.  When 

we click on the number 6, the number changes to follow our index field and becomes 4 

(one more than 3—our index).   

 

Figure Error! No text of specified style in document..93: Tab Order Adjusted Manually – Before and After 



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-86 

 

4. Click each successive field’s tab order box in the desired flow and the numbers are 

updated sequentially.  In our example, we clicked on the tab order boxes 9, 12, 15, and 

18 to set the order to be 5 through 8 consecutively.   

 

Figure Error! No text of specified style in document..94: Additional Tab Order Options 

5. After clicking the tab number at the bottom of the first column, move the mouse up to 

the first field of the second column to continue the sequence.  Continue clicking each 

successive tab order number until you are finished.  Click anywhere on the canvas to 

hide the tab order numbers. 

 

 
 

Figure Error! No text of specified style in document..95: Additional Tab Order Options 
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Customize Tab Order using ‘Continue Tab Order’ 

The Continue Tab Order feature sequentially renumbers the tab order for a selected set of 

fields based on the current index value.  As an example, the figure below shows the original 

tab order in the Food History form of the EColi project located in the Projects folder. 

 

Figure Error! No text of specified style in document..96: Customize Tab Order 

 

In order to have the order run down the first column, from ‘Fresh celery’ to ‘Bean sprouts’, 

then over to ‘Grapes’ in the second column using the Continue Tab Order option, follow 

these steps: 

1. Click and drag a rectangle around the first column of fields.  This will select just 

those fields. 
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Figure Error! No text of specified style in document..97: Click and Drag Column of Fields for Tab Order 

2. Right click the canvas and select  Tabs > Start New Tab Order.  This will reorder 

only the selected fields beginning with the first tab order number. 

 

Figure Error! No text of specified style in document..98: Start New Tab Order 

3. Click and drag a rectangle around the second column of fields to select them. 
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Figure Error! No text of specified style in document..99: Grouping Tab Order 

4. Right click on the canvas and select Tabs > Continue Tab Order.  This will 

reorder the second column of fields continuing from the last Tab Order Number used 

in the previous action. 

  
Figure Error! No text of specified style in document..100: Continue Tab Order 

5. Repeat steps 3 and 4 until all fields’ Tab Order are renumbered as needed. 

 

Disable Tab 

The Disable Tab feature makes the field essentially a Read-Only field that does not receive 

the cursor.  In the example shown in the figures that follow, the Age field is calculated in 

Check Code based on the value entered for Birth Date.  Therefore, the designer of this form 

wants the cursor to skip over the Age field by disabling its tab. 

1. Right click the canvas and select Tabs > Show Tab Order from the context menu. 
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2. Right click on the desired field’s tab order box and select Disable Tab. 

  
Figure Error! No text of specified style in document..101: Disable Tab 

After disabling the Tab for a field, the tab order box becomes red to indicate that it is no 

longer a field that will receive the cursor.  Pressing the tab key will bypass any disabled 

tabs.  

 

Figure Error! No text of specified style in document..102: Bypassing Disabled Tabs 

 

 

Note:  Check Code only runs when the cursor enters a field. If a field’s tab order is 

disabled, Check Code will not run for that field. 
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Templates 

 

Templates are a time-saving feature that allows you to save all or part of your project to be 

reused in other projects and shared with other Epi Info™ 7 users without sharing data 

collected with the project.  For example, you might want to save certain fields for use on 

forms you will create later, as opposed to having to create those same fields over and over ( 

e.g. case demographic information). Saving fields for later use could also be a good way to 

have a library of fields already built and ready to go in case of a public health emergency.  

Templates are saved to the Epi Info™ Templates folder using the Extensible Markup 

Language (XML) format.  There are four types of templates: Field, Page, Form, and Project.   

Epi Info™ 7 is packaged with a number of project and field level templates that 

demonstrate many of the various field types and features of Epi Info™ 7 including some 

Check Code examples.  These are listed in the Project Explorer under the Templates 

category. 

One of the best ways to see how Epi Info can be used is to create a project using these 

templates and examine how they were done.  A new project can be created from one of the 

sample Project Templates in the Form Designer when you open it for the first time.  

 

Figure Error! No text of specified style in document..103: Project Explorer Template 
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Project Templates 

Since Epi Info™ 7 Projects contain one or more forms, and each form has one or more pages 

with fields, Project Templates contain an example of all of the above including any Check 

Code that may have been saved with the template.  Project templates are an effective and 

convenient way to share projects between colleagues without including collected data.  

Create a New Project From Template 

A list of demonstration templates are located in the Project Explorer under Templates > 

Projects.  Use one of them to create a new project. 

1. Double-click the template of choice or select File > New Project from Template.  

The New Project from Template dialog opens.  

 

 
Figure Error! No text of specified style in document..103: New Project from Template 

2. Select a template from the list.  The Name and Data Repository used when the 

template was created is automatically populated in their respective fields. 

3. Edit the Project Name, if necessary (optional). 

4. The default location for the project is the Projects folder within the Epi Info™ 7 

folder.  Specify another location, if necessary (optional). 

5. Select the database format from the Data Repository drop-down list. The default 

option is Microsoft Access 2000-2003, however SQL Server is also available. To use 

the SQL Server option, you need to have access to a SQL Server database. 
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6. If you selected Microsoft SQL Server for the Data Repository, then click the browse 

button (…) to the right of the Data Repository field to enter the connection 

information for the SQL Server database.  Contact your SQL Server database 

administrator for the required information requested in this dialog. 

 

 
Figure Error! No text of specified style in document..1044: SQL Server Database Dialog Box 

 

7. Click OK.  The Form Designer creates the project and after a few moments, the new 

project appears with the first form’s initial page shown on the canvas. 

For additional information on creating new projects, refer to the topic Create a New Blank 

Project and Form. 

 

Create a New Template from a Project 

There are two options to create a project template that includes all the forms, pages, fields, 

and Check Code in the current project – Save Project as Template, which allows you to 

specify a template name and description, and Quick Save Project as Template which 

automatically names the template based on the project name and the current date and 

time.  Both options save the template in the same way, but Quick Save does not allow for a 

custom name and description. 
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1. In the Project Explorer, right click on the project name.  The project name is the 

top most item in the Project Explorer.   

2. From the drop-down list, select Save Project as Template or Quick Save Project 

as Template.   If Quick Save Project as Template is selected, the template is 

immediately saved to the Templates > Projects folder with the name of the project 

and a timestamp. 

 

Figure Error! No text of specified style in document..1055: Save Project as Template 

 

3. If the ‘Save Project as Template’ option is selected, a dialog appears to allow you 

to add a Template Name and an optional Description. 

 

Figure Error! No text of specified style in document..1066: Save Project as Template Description 
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4. Click OK.  The template is saved to the Templates > Projects folder. 

5. To retrieve the template to send to someone, locate the template in the Project 

Explorer. 

6. Right click the template name and select Open Containing Folder.  This opens 

the folder in Windows Explorer.  From Windows Explorer, you can copy and paste 

the XML template file into an email or save it to a shared network location for 

others to use. 

 

Figure Error! No text of specified style in document..1077: Open Containing Folder 

Get Template 

If you receive a template from a colleague, an easy way to copy the template to the correct 

location within Epi Info™ 7 is to use the Get Template feature.   

1. From the Form Designer menu, select File > Get Template…  The Open dialog 

appears. 

2. Locate the template file. 

3. Click Open.  The template is saved to the corresponding Epi Info 7 > Templates 

folder according to the type of template.  If the template is a Project template, then 

the New Project from Template dialog opens. 



Epi Info™ 7 User Guide – Chapter 2 – Form Designer 

2-96 

 

 
Figure Error! No text of specified style in document..1088: Get Templates 
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Form and Page Templates 

Form and Page templates are created and used in similar ways.  The difference is in the 

item selected when right clicking to get the context menu.  Also, form templates can be used 

to create a single form project, whereas a page template can only be added to a form in an 

exising project.  

Create a Form Template 

If you want the template to include all the pages and associated Check Code for a given 

form then right click the form name in the Project Explorer and select Save Form as 

Template.  In the example shown below, the form ‘Surveillance’ along with its three pages, 

‘Person’, ‘Hospital Info’, and ‘Case Report’, will be included in the template along with all 

associated Check Code. 

 

Figure Error! No text of specified style in document..1099: Save Form as Template 

 

Create a Page Template 

If you want the template to include the contents of a specific page, and the Check Code for 

the fields on that page, then right click the page name in the Project Explorer and select 

Save Page as Template.  In this example, only the selected page ‘Hospital Info’ and its 

Check Code will be in the template. 
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Figure Error! No text of specified style in document..110: Save Page as Template 

 

The Add Template dialog appears for you to enter a Template Name. 

 

 
Figure Error! No text of specified style in document..111: Add Template dialog box 

Click OK. The page template is created and saved to the respective folder under 

Templates in the Project Explorer. 

How to Use Form and Page Templates 

Form and Page Templates are very similar in the way they are used.  In order to use either 

template, there must be an existing Project already open in the Form Designer.  The 

difference is that a Form Template contains the instructions to create a set of pages, each 

with one or more fields and Check Code, if any.  A Page Template has only the page layout 
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information and instructions to create the fields on a single page along with Check Code, if 

any. 

Since all field names and page names must be unique within a given form, a new form 

created from a Form Template requires very little additional work to make the form usable 

after it is created from a Form Template. 

A Page Template, on the other hand, can be used repeatedly on a given form.  Because of 

this, during the process of creating the new page from a Page Template, if any field names 

already exist for the form, Epi Info™ 7 automatically appends a number to new field name 

from the template.  Epi Info™ 7 does this to avoid having any duplicate field names.  

Unfortunately, this has the side effect of potentially breaking the Check Code that may 

exist for that page template.  The field names within the Check Code are not synchronized.  

Therefore, the Check Code must be manually updated with the new field names. 

To use a Form or Page Template, follow these steps: 

1. With a project open in Form Designer, locate the template in the Project Explorer – 

Templates > Forms for form templates, or Templates > Pages for a page 

template. 

2. If you cannot find the template you need, but you know it is saved somewhere, use 

the File > Get Template… feature to browse for the template. 

3. Click and Drag the template to the canvas.  Epi Info™ 7 will create the new form or 

page and place it in the Project Explorer. 

4. If a page template was used, to change the page order, clicking and drag the page in 

the Project Explorer to the appropriate position. 

 

Field Templates 

Field templates allow for easy and concise duplication and sharing of fields and enable 

consistent collection of routine information.  When a survey needs to have several questions 

asked in the same way, as in a Likert scale, it is easiest to set up one or two or a few of 

these questions, save them as a field template, then add additional sets of questions to the 

form from the template.  This method only requires updating the prompt and field name 

properties of the new fields. 

Each field template includes the field definition and attributes for one or more fields, along 

with any Check Code written for the selected fields.  A list of demonstration field templates 

are available in the Project Explorer under Templates > Fields. 

How to Create a Field Template 

A convenient way to reuse a field or set of fields along with their Check Code or to share 

fields with a colleague, is to create a Field Template.  To do this, follow these steps: 
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1. Select the fields to add to the template by drawing a rectangle around them. To do 

that, click and drag the mouse from the top left of the desired fields diagonally down 

to the lower right until all needed fields are contained in the blue box. 

 

Figure Error! No text of specified style in document..112: Drag a rectangle to Select Fields 

2. Release the mouse button and the selected fields will remain highlighted. 

 
Figure Error! No text of specified style in document..113: Selected Fields appear with blue border 

3. Right click on a blank area of the canvas. Select Save Selection as Template from 

the context menu. 
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Figure Error! No text of specified style in document..114: Create New Field Template 

Note: Right clicking on a field or field group will not display the proper menu 

options to create a field template. Right click on a blank portion of the canvas 

only. 
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4. Enter a Template Name in the Add Template dialog box. 

 
Figure Error! No text of specified style in document..115: Field Template Name 

5. Click OK. The field template appears under Templates > Fields in the Project 

Explorer.  

Using Field Templates 

To use a Field Template to create a new set of fields, follow these steps: 

1.  Locate the Field Template in the Project Explorer. 

 
 

Figure Error! No text of specified style in document..116: Field Template drop-down list 
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2. If you cannot find the template you need, but you know it is saved somewhere, use 

the File > Get Template… feature to browse for the template. 

3. Click and drag the desired template from the Project Explorer onto the page in 

the appropriate location.  As you drag the template over the canvas, you will see a 

blue rectangle showing the approximate footprint that the fields will occupy when 

created.  

4. Drop the template where new field(s) should be placed. When the template is 

released, Epi Info™ 7 will create the new fields and copy the associated Check Code 

into the Check Code Editor. 

  
 

Figure Error! No text of specified style in document..117: Drag Field Template to Canvas 

Epi Info™ 7 creates fields from Field Templates using the field name specified in the 

template UNLESS a field by that name already exists on the form, perhaps on another 

page.  To avoid duplicate field names within a given form, Epi Info™ 7 automatically 

appends a number to the field name of any field that already exists in the same Epi Info 

Form.  Unfortunately, this has the side effect of potentially breaking the Check Code that 

may exist for the new fields.  The field names within the Check Code are not synchronized.  

Therefore, the Check Code must be manually updated with any new field names. 
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5. For each new field created from the template, right click the field and select 

Properties.  The Field Property dialog box for the selected field opens.  Notice the 

Field Name.   

 

Figure Error! No text of specified style in document..118: Open the Properties for new fields. 

6. If a data table has not been created for the form, edit the Field Name and other 

properties as needed. 

  
Figure Error! No text of specified style in document..119: Customize the new fields’ names, question, and 

properties. 
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Sample Field Templates for Demonstration 

There are several field templates that are packaged with Epi Info™ 7 for demonstration 

purposes.  While these fields could be used “As Is” for data collection, these field templates 

and the Check Code they contain are meant to illustrate the features and functions of Epi 

Info™ 7.   

Demographics 

The demographics template has common fields used to for patient information.  Some of the 

fields originate from the Public Health Information Network (PHIN) vocabulary set such as 

Sex and Ethnicity Group.  

 

Field Types Illustrated: 

 Text 

 Comment Legal 

Drop Down 

 Phone Number 

 Checkbox 

 Group 

 Number 

 Multiline 

 Command Button 

 
Figure Error! No text of specified style in document..120: Demographics Field Template 
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Diagnosis 

The diagnosis template contains multiple Yes-No fields related to common patient 

diagnoses. The template also includes text fields for collecting additional information. 

 
Figure Error! No text of specified style in document..121: Diagnosis Field Template 

Geo-location 

The geo-location field template contains fields for Address, Latitude, and Longitude.  It also 

has a command button, Get Coordinates for which Check Code was written using the 

GEOCODE command.  This command uses a geolocation service to populate the Latitude 

and Longitude fields with coordinates based on the information entered into the Address 

field. These coordinates can then be used in mapping functions in the Epi Info™ Maps tool. 

 
Figure Error! No text of specified style in document..122: Geo_Location Field Template 

Medical Facility 

The Medical Facility template contains fields commonly used to collect medical facility 

information. 
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Figure Error! No text of specified style in document..123: Medical Facility Field Template 

States 

The States field template is an example of a comment legal field.  Comment legal fields 

store only the code or abbreviation in the database, but the full description is shown in the 

drop-down list.  The data source for this field includes all state and territory names and 

abbreviations for the United States of America in sorted order (alphabetical).   

 
Figure Error! No text of specified style in document..124: States Field Template 

 

 

Additional Functionality in Form Designer 

 

Insert a Line  

It is sometimes helpful to add a horizontal line between groups of fields to give a visual 

separation between sections of the page. A line can be created using the Label/Title field.   
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 Figure Error! No text of specified style in document..125: Horizontal Line Functionality 

To create a line on your page, follow these steps: 

1. Right click on the canvas where you want to add a line. Select New Field > 

Label/Title. 

2. In the Question or Prompt field, hold the SHIFT key and type an underscore to create 

a line. 

3. Click the Font button. The Font dialog box opens. 

4. Select a font size and bold. 

5. Click OK. 

6. Create a Field Name for the label field. 

7. Click OK. The line appears in the form. 

8. The line can be resized, moved, copied and pasted as needed. 

 

Upgrade Project 

To use a project from a previous version of Epi Info™ in Epi Info™ 7, the project must be 

upgraded to the proper format. The upgrade project tool allows users to browse and identify 

previous projects and upgrade the projects for use in Epi Info™ 7. Select Tools > Upgrade 

Project > Epi Info 3.5x (.MDB). 
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Figure Error! No text of specified style in document..126: Upgrade Project 

Browse and select the desired project. Click Open. The project is upgraded to Epi Info™ 7 

and is available for use. 

 

Make a Project File (PRJ) 

Occasionally, you may receive an Epi Info™ 7 database--either the Access .MDB file or the 

location of the database on a SQL Server.  If this database is by itself, and if you do not 

have the corresponding Project File (.prj), then Epi Info™ 7 will not be able to work with it 

until you create a new Project File.   

To create a new Project File for a given Epi Info™ 7 database, follow these steps: 

1. From the Form Designer Tools menu, select Make PRJ File. 

 
Figure Error! No text of specified style in document..127: Make PRJ file 

2. If the database you are attempting to use is a Microsoft Access database, .MDB, 

then select From Epi Info™ 7 project (MS Access).  

For a SQL Server database, select From Epi Info™ 7 project (SQL Server). 

3. For Access files, browse for the desired MDB file and click Open.  A new project file 

is created from the source MDB.  The original MDB is not changed so it can be 

opened in the older version after the migraion, however, any changes made to that 

original database will not be in the new upgraded version. 
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4. For SQL Server databases, you will be asked for the connection information for the 

SQL Server.  See your SQL Server Database Administrator for the necessary 

connection information. 

 

Delete an Existing Data Table Without Deleting the Form 

To delete an existing data table without deleting the form, perform the following steps: 

1. From the Form Designer toolbar, select Tools > Delete Data Table. The Form 

Designer warning message appears. 

 
Figure Error! No text of specified style in document..128: Delete Data Table 

2. Click Yes. The data table associated with your form is deleted. The form remains 

intact. 

 If the data table is deleted, any entered data associated with the form are deleted 

from the project. Be absolutely sure you do not need the records. 

Note: This function should be used only if the data is expendable. This action is 

permanent and irreversible. 

 

View a Data Dictionary 

From the Form Designer toolbar, select. The resulting grid shows the name of the fields in 

the “Name” column. These names correspond to the column names in the data tables that 

you will need to use when performing analyses.  

The Data Dictionary displays form(s) and defined variables for an open project. Fields or 

variables are sorted and displayed by page number in the form with defined variables 

appearing at the end of the listing. Information retrieved from the form includes Page 

Number, Tab Index, Prompt, Field Type, Name, Variable Type, Format, and Special Info. 

From the Form Designer toolbar, select Tools > Data Dictionary. The Data Dictionary 

table appears on the canvas.  
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Figure Error! No text of specified style in document..129: Data Dictionary 
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 Page Number values are developed each time a page is added and corresponds to 

the page location in the Project Explorer. 

 Tab Index corresponds to the tab order for each field. 

 Prompt, Field Type, Name and Variable type correspond to the specifications in 

the Field Definition dialog box for each variable. 

 Format column values include selected patterns for number, date, date-time, 

phone number (anything with a pattern or format) fields and sorted for combo 

boxes. Combo box is a combination of list box and a drop-down list (legal values, 

combo). 

 Special Info column values include all properties available from the Field 

Definition dialog box. Properties include Read Only, Legal Value, Repeat Last, 

Code Table, Groups, Required, Range, and Image Size. The Special Info column 

also holds the defined variables values of Standard, Global, or Permanent. The 

Special Info column includes information on related fields to indicate whether 

they contain one record or an unlimited number of records. This is developed 

when the related field is created. The default is Unlimited Records. If the Return 

to the Parent Form after One Record has been Entered box is checked, the 

format will appear as one record. 

To view a data table located in another form: 

1. Click Selected View. The Selected View drop-down list opens. 

2. Select the form to view.  

3. The Data Dictionary for the selected form opens. Note that only the Data Dictionary 

for the selected form opens. 

To open the Data Dictionary as an HTML page inside the browser window: 

1. Click View/Print as Web Page.  

Note: From the browser, the data can be printed with File > Print, or saved with 

File > Save As. 

2. Right click on the HTML page to show the context menu. You can export the data 

directly to an Excel spreadsheet or print the document. 
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Figure Error! No text of specified style in document..130: Data Dictionary as an HTML Page 

3. Click Close to exit the Data Dictionary. 

 

Make Form from Data Table 

The Make Form from Data Table feature allows you to automatically generate an Epi Info 7 

form based on an existing database file.  Once completed, you will have the initial structure 

of a form that could be modified further if needed.  Field types, code reference tables and 

field prompts can be specified during the process.  Formats supported include MS Excel, 

MS Access, Flat ASCII, SQL Server and MySQL among other types. 

For example, let’s say that you have an Excel spreadsheet with data that you have 

historically maintained using MS Excel but would like to create an Epi Info project to 

collect the data and enjoy the benefits that can be obtained from entering data using Epi 

Info 7.  This feature allows users to do so. 

The first step will require you to create an Epi Info 7 project.  When prompted for a Form 

Name, assign any name to the form.  This initial form will be deleted eventually after the 

import process from the MS Excel file is completed. 

1. From the Epi Info main menu, select Utilities > Make Form from Data Table. The 

Make Form from Table dialog opens. 

2. Select the desired Database Type. In this example, we will select Microsoft MS Excel 

97-2003 Workbook. 

3. Navigate to the location of the file. 

4. Click on the name of the spreadsheet that contains the dataset you would like to import 

into Epi Info 7.  

5. Specify a form name. 
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Figure Error! No text of specified style in document..131: Make Form from Table dialog 
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6. Click OK. The Table-to-Form dialog opens. 

 

 

Figure Error! No text of specified style in document..132: Table-to-Form dialog 

7. Click Set Prompt Font and Set Field Font to set the fonts for the question/prompts 

and the input fields, respectively. 

8. If any of the columns in the source table are to become a Legal Value field type, then 

click Add List Source Table and browse for the table that contains the list of valid 

values.  This will be needed below for the ListSourceTableName column. 

A series of columns are displayed.  Here is a description of each column: 

 Import- This check box allows you to select which fields should be imported into the 

form and turn off the import for other fields..  By default, all fields are checked. 

 Column Name- This specifies the column name from the source table.  The column 

name is initially used for the field name and prompt. 

 Field Name- The field name is initially the same as the column name, but you can 

change it now. If the field name is an Epi Info reserved word, the Table-to-Form 

process will change it automatically by adding a suffix of “_RW”.  You may want to 

change this name to something more relavent.  Note: Be sure these field names 

are adequate before starting the conversion because they cannot be changed 

after the data tables are created. 

 Prompt- The prompt is initially the same as the field name.  You can change it now 

here, or later by visiting the properties for the field. 
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 Column Type – This is the type of data that Epi Info™ 7 detected.   

 Field Type – This specifies the type of field that probably corresponds to the 

Column Type.  For example, if Epi Info™ 7 detects string data for the column type, 

then it will suggest the type of field to hold this data might be a Text field.  You can 

override this decision if you know what the data repesent.  For example, if the 

column contains only “Yes” and “No” values, Epi Info™ may suggest the Text field, 

but you may decide the YesNo field type is more appropriate.  Available field types 

include: Text, Multiline, Number, YesNo, Checkbox, Date, Date-Time, Time, and 

Legal Values. 

 Page- For tables having many columns, Epi Info™ will place the fields on the form 

based on the order they appear on the source table.  It will stack as many fields as 

will fit on the first page, then it will continue to add pages and stacking fields as 

needed to accommodate the all of the columns.  You can use the Page column to 

instruct Epi Info™ to keep certain fields together on a specific page.   

Note: There is a limit of about 250 fields on any given page. 

 Tab- This specifies the order of the field within the page during data entry.  

 Tab stop- If data entry will occur for a field, then this should remain checked.  

Some fields are automatically calculated, so these would not need a Tab stop and 

therefore the Tab stop checkbox should be unchecked.  When Tab Stop is unchecked, 

the cursor will not move into the field during data entry. 

 Read only- This check box sets the Read Only attribute of the field.  If checked, the 

field will be disabled. By default, it is unchecked. 

 Required – Fields where data entry is manditory should have this Required 

attribute checked.  By default, it is unchecked.  

 Repeat last  - When checked, the Repeat Last attribute causes the value of the 

most recently viewed record to become the pre-populated values when a new record 

is created.  By default, it is unchecked. 

 Range - Allows for a specified value between one value and another. During data 

entry, if you attempt to enter a value outside the specified range, you’ll get a 

warning message that the value is out of range. Missing values are accepted. By 

default, it is unchecked.  If you check the Range check box, then also specify the 

Lower and Upper ranges as described below. 

 Lower- Specify the smallest or lowest value that can be entered into the field. 

 Upper - Specify the largest or highest value that can be accepted by the field. 

 List Source Table Name – If a reference table has been imported using the Add 

List Source Table option, the field can be linked to one of the imported tables.  This 

only applies to Legal Value fields. 

 List Source Text Column Name – If more than one column is available on the 

imported reference table, specify which column name should be used to map to the 

field from within the table. 

 List Source Table- Fields can be removed from the View Fields list using the back 

single arrow or back double arrows. 

9. Click Convert to start the import process. 

The process of creating the form and importing the process begins. Once the process is 

completed, the message “Table to form import process complete” message appears. 
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Figure Error! No text of specified style in document..133: In Progress dialog window 

 

Figure Error! No text of specified style in document..134: Process completed dialog window 

 

After the import process has completed, you can make some changes to the form such as 

alignment, font, and adding labels and titles.  However, do not cut and paste fields from one 

page to another.  If you intend to move fields across pages after the import, we strongly 

recommended that you first Delete Data Tables Without Deleting the Form, move the 

fields to the necessary pages, then Use the MERGE Command in Classic Analysis to 

merge the data into the revised form.  

 

Figure Error! No text of specified style in document..135: Cutting and Pasting fields 
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